0

I am trying to configure a computer on Zaphode mode. The machine is running Linux Mint 19.2. The graphic card is not working properly. I first need make it work so I can work on Zaphode mode.

The computer uses a grpahic card named TN 750. Its just a PCI wrapper for a SoC named SM750 from Silicon Motion.

After many, many days I succeeded in displaying text mode on the graphic card. By default when I boot Linux Mint, it briefly shows the Linux Mint logo and then the image freezes black with a frozen cursor.

I can switch to tty1, for instance, using ctrl + alt + f1. There, I run

sudo startx xterm -- :1 vt2

but then again I got a frozen image. I can still switch among the others tty. I know that the SM750 has a framebuffer driver named sm750fb that is loaded by default. Checking Xorg.0.log it seems that it tries to load VESA and fbdev drivers for the graphic card.

If I run htop, I can see the following process:

Here are the logs for xorg:

Xorg.0.log: https://pastebin.com/HgE4iMu8

ps -aux:

ps -aux | grep Xorg
root       844  0.5  1.1 453240 38508 tty7     Ssl+ 00:29   0:01 /usr/lib/xorg/Xorg -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

lspci:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Silicon Motion, Inc. SM750 (rev a1)

I also installed a xf86 driver from siliconmotion. It also seems that X tries to use it but as I don't understand very well the logs, I am unsure of what is going on.

apt-cache search siliconmotion
xserver-xorg-video-siliconmotion - X.Org X server -- SiliconMotion display driver
xserver-xorg-video-siliconmotion-hwe-16.04 - Transitional package for xserver-xorg-video-siliconmotion-hwe-16.04

My last hope is that I can use at least this graphic card at VESA mode on zaphode mode. But first I need to find out why there is no graphical output

1 Answer 1

0

I'm afraid the xserver-xorg-video-siliconmotion is from the Xorg project and for much older Silicon Motion chips only.

The siliconmotion driver supports PCI and AGP video cards based on the following Silicon Motion chips:

  • Lynx SM910
  • LynxE SM810
  • Lynx3D SM820
  • LynxEM SM710
  • LynxEM+ SM712
  • Lynx3DM SM720
  • Cougar3DR SM731
  • MSOC SM501,SM502

The current download page of SiliconMotion offers downloads only for the SM76x (which may or may not be related to SM750) for Windows, macOS and Android only.

From your log, the X server seems to be initially using the modesetting driver, but fails to detect any connected outputs:

[    19.876] (II) modeset(0): Output VGA-1 disconnected
[    19.876] (II) modeset(0): Output HDMI-1 disconnected
[    19.876] (II) modeset(0): Output DP-1 disconnected
[    19.876] (WW) modeset(0): No outputs definitely connected, trying again...
[    19.876] (II) modeset(0): Output VGA-1 disconnected
[    19.876] (II) modeset(0): Output HDMI-1 disconnected
[    19.876] (II) modeset(0): Output DP-1 disconnected
[    19.876] (WW) modeset(0): Unable to find connected outputs - setting 1024x768 initial framebuffer

On the other hand, these might be the outputs of the iGPU within your CPU.

The sm750fb driver seems to be in a "staging" directory, so it might be a bit rough around the edges yet. Its README file suggests there might be some things you'll need to take into account:

Important: if you have vesafb enabled in your config then /dev/fb0 will be created by vesafb and this driver will use fb1, fb2. In that case, you need to configure your X-server to use fb1. Another simple althernative is to disable vesafb from your config.

According to that, adding Option "fbdev" "/dev/fb1" to your X server configuration might be helpful. See the man page of the fbdev driver for more info.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .