9

Somewhat related to how to pipe audio output to mic input and https://askubuntu.com/questions/602593/whats-a-good-soundflower-replacement-for-ubuntu but those both involve "recording".

I want to play a movie trailer or just any video on a screenshare in Zoom and have the audio that I hear also go to attendees/viewers. I installed pavucontrol and do have the ability to list "monitors" on the inputs tab, but those "monitor of" inputs don't show up as input/mics in zoom.

I feel like I need the ability to re-tag these "monitor of" inputs to not be "monitor" types so that they show up as an input source in Zoom.

How can I get the output to be an input in Zoom?

6

We had exactly the same problem with Zoom in Linux (Ubuntu, Lubuntu and Gentoo). The solution turned out to be as follows, and does not require using PulseAudio Volume Control:

  1. Launch the application for playing audio or video. Pause the audio/video if necessary.

  2. Click on 'Mute' in Zoom, to mute the mic (see NOTE below).

  3. Click on 'Share' at the middle bottom of the Zoom window, select the application (or 'Desktop') and either a) click 'Advanced' if you only want to share audio, or b) click on 'Share computer sound' and on 'Optimise Screen Sharing for Video Clip' if you want to share a video.

  4. Click the blue 'Share' button.

  5. Unpause/start the audio/video playing in the audio/video application.

NOTE: We find we get much better audio quality by muting the mic before sharing audio/video. After starting the audio/video stream, it is then possible to unmute the mic.

0
6

Make Zoom accept monitor as input (Ubuntu 20.04)

With the new PulseAudio version 13.99+, you can no longer select "System default" as mic in Zoom, which was a way of tricking Zoom into using a monitor as input. You have to create a virtual source:

pactl load-module module-null-sink sink_name=zoom_input sink_properties=device.description=zoom_input
pactl load-module module-remap-source master=zoom_input.monitor source_name=zoom_mic source_properties=device.description="zoom_mic"

By doing this, "zoom_mic" will show up as a input device in Zoom.

Using pavucontrol, redirect the sound from your media player to "zoom_input" and it will be played in Zoom.

See also this advanced guide to PulseAudio connections: https://github.com/toadjaune/pulseaudio-config

1
1

In the Zoom share tool, there is a check box for "Share Computer Audio". This works, sort of, it is highly distorted audio which seems overdriven at some level.

3
  • Thanks, which operating system? It isn't present on my Arch AUR package. Mar 24 '20 at 23:32
  • 2
    That solves the OP's problem, but what if I want to pipe my audio output to Zoom without sharing my screen? pavucontrol doesn't let me change the input device for Zoom's audio engine. I'm looking for a trick to do that.
    – Nadav S.
    Apr 10 '20 at 22:04
  • 1
    A few months late & off the original topic, but when you click Zoom's screen share button, the resulting box has an "Advanced" tab that will share system audio without any video. Sep 5 '20 at 17:04
1

This script works You'll need to set mic in zoom to default rather than mic and in pavucontrol set your mic to 'zoom' and vlc or whatever to media.

(adapted from Manjaro forum) you'll still get some distortion due to zooms so-called audio enhancements which you can't disable in the linux app.

#!/bin/bash
pactl load-module module-null-sink sink_name=zoom sink_properties=device.description=zoom
pactl load-module module-loopback sink=zoom
pactl set-default-source zoom.monitor
pactl load-module module-null-sink sink_name=media sink_properties=device.description=media
pactl load-module module-loopback source=media.monitor
pactl load-module module-loopback source=media.monitor sink=zoom
0

I was having similar problems to txneo999 (highly distorted audio) as I was digging through settings assuming there was a volume level over-driving the signal I stumbled across "sample spec:" in pacmd list-sources - It was at 44100Hz for the zoom device.

My system (UbuntuStudio 18.04) was set at 96000Hz when I set it down to where Zoom was at 44100Hz the distortion is gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.