I am running Webmin on Debian, configured to use SSL. The certificate is about to expire, so I generated a new one and imported it using the GUI (pasted cert and key in PEM format, reused existing chain file).

Now Webmin will insist on speaking plain HTTP on that port. When I try to log in, it rejects my user credentials (local user account).

I opened an SSH session on the server and examined /etc/webmin/miniserv.*. The .cert and .pem file have an updated timestamp and their contents appear to match what I uploaded. The .conf file also has a recent timestamp, though I have no idea what has changed here.

EDIT: I have tried manually replacing miniserv.cert and miniserv.pem with the previous cert and key files, then restarting Webmin. No change—the server responds in plain HTTP and my login no longer works.

What gives?

  • Update: I ended up restoring the system from a previous image, then updated the certificate by modifying the files directly. This worked; not sure what broke things on update.
    – user149408
    Feb 9, 2020 at 18:40

1 Answer 1


Please doublecheck your server logs for error regarding the webserver cert usage and test your certificate with openssl

openssl s_client -showcerts -connect yourservername.domain.tld:yourport
  • If the server starts answering in plain HTTP on what should be its SSL port (as in my case), this won’t tell me anything I don’t know already…
    – user149408
    Feb 3, 2020 at 23:30
  • Sorry for missunderstandig you Feb 5, 2020 at 6:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .