0

I am sorry if this is a silly question or someone has already answered it.

I am new to linux and encounter a problem with booting into OS (Qubes OS 4.0.1). After some time searching about the problem, I found a possible solution (comment by notbyosmosis). However, in the guide they said to modify lvm config file.

After I typed "/etc/lvm/lvm.conf" I got the following message:

sh: /etc/lvm/lvm.conf: Permission denied

I didn't manage to find information on how to get the permission. All the suggestions I've found require to do everything from os.

Is there a chance to get the permission without reinstalling the os?

OS partition is encrypted if it's matter.

Thank you in advance!

3
  • By typing /etc/lvm/lvm.conf you are trying to run the lvm.conf file, which is not possible since it is a configuration file, not an executable. You will need to start a text editor to modify the file, e.g. nano /etc/lvm/lvm.conf if yor system has the nano text editor available (it's quite small and user friendly, so it might be installed by default).
    – telcoM
    Dec 19 '19 at 9:18
  • Hello @telcoM and thank you for the explanation! Unfortunately, I don't have nano, vim, or emacs installed on my dracut emergency shell.
    – Plutonium
    Dec 19 '19 at 9:31
  • I've tried to access the file from OS installed on a USB driver, but I didn't success in finding it.
    – Plutonium
    Dec 19 '19 at 9:34
0

Yeah, it was a silly question.

It turned out that I have vim on my pc, however I tried to run it via 'vim' instead of 'vi'.

Now my problem is solved and I can successfully boot into my os.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.