The whole problem started at an airport, where I wasn't able to connect to WiFi on my Pop!_OS laptop. I Googled the problem on another device, and found this StackOverflow answer. Though the first answer (typing in route to find the login IP address) worked in the first airport, it didn't on the second, so I tried all of the remaining answers.

First attempt:

sudo dpkg-reconfigure resolvconf

This gave me the message: resolvconf-pull-resolved.service is a disabled or a static unit, not starting it.

Second attempt: Edited /etc/NetworkManager/conf.d/20-connectivity-debian.conf. This didn't help either. Now, my DNS wouldn't work even when connecting to my iPhone hotspot, and, later, when I got home, to my regular home network! I tried deleting the contents of the file, but no luck.

Other things I tried: - Toggling Privacy/Connectivity Checking - Making sure my Network Proxy was off - Toggling WiFi - Rebooting - Restarting network service - Connecting to my iPhone hotspot over Bluetooth - Connecting to my iPhone hotspot over USB

Other Random Problems This Caused

  • Running commands with sudo threw error unable to resolve host

Right now: I'm connected to my home network. I can visit some sites (like but can't visit sites from the address bar. I'd like to keep the automatic DNS provided by my home network.

Tl;DR: How can I fix my internet? How can I connect to captive portal public wifi in the future?

  • What are the contents of /etc/resolv.conf? In modern laptop linux this should normally just contain nameserver since your DNS is likely managed with dnsmasq. You can temporarily fix the problem by making it point to some external DNS: nameserver for OpenDNS.
    – xenoid
    Dec 18, 2019 at 17:08
  • @xenoid it says: ``` # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN # is the systemd-resolved stub resolver. # run "systemd-resolve --status" to see details about the actual nameservers. nameserver ```
    – Ben Gubler
    Dec 18, 2019 at 21:12
  • @xenoid I think the problem may be that I tried to get resolvconf to run my DNS, but it couldn't install correctly since there wasn't internet?
    – Ben Gubler
    Dec 18, 2019 at 21:16
  • @xenoid I can confirm that fixes the problem. Is there a more long-term solution?
    – Ben Gubler
    Dec 18, 2019 at 23:11
  • Now that you have working internet, try to reinstall/reconfig resolvconf, and if that works reinstate the initial resolv.conf if not done by the reinstall.
    – xenoid
    Dec 18, 2019 at 23:24

1 Answer 1



I edited /etc/resolv.conf and replaced:

nameserver with nameserver

So I could get internet in the meantime. Then, after seeing this AskUbuntu answer, I ran:

sudo apt-get remove --purge resolvconf && sudo apt-get install resolvconf

And rebooted my computer.

  • The temporary fix works. But purging and reinstalling resolvconf fixed nothing for me.
    – Benjamin R
    Sep 5, 2021 at 8:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .