1

I recently installed Fedora Silverblue on Virtualbox. I tried to install the Virtualbox Guest Additions but it always fails. First, I tried:

sudo rpm-ostree install virtualbox-guest-additions

But I got:

error: "virtualbox-guest-additions" is already provided by: virtualbox-guest- additions-6.0.4-2.fc30.x86_64. Use --allow-inactive to explicitly require it.

The system says that the Virtualbox Guest Additions are already installed but it does not work. After that, I tried installing it via the ISO image but it does not work too because it is a read file system which I understand.

So, does anyone know how to install the Virtualbox Guest Additions on Fedora Silverblue?

EDIT:

sudo modprobe -v vboxvideo gives me:

insmod /lib/modules/5.3.15-300.fc31.x86_64/kernel/drivers/gpu/drm/drm_vram_helper.ko.xz
insmod /lib/modules/5.3.15-300.fc31.x86_64/kernel/drivers/gpu/drm/vboxvideo/vboxvideo.ko.xz

And this is the output for modinfo vboxguest:

filename:        /lib/modules/5.3.15-300.fc31.x86_64/kernel/drivers/virt/vboxguest/vboxguest.ko.xz
license:          GPL
description:      Oracle VM VirtualBox Guest Additions for Linux Module
author:           Oracle Corporation
alias:            pci:v000080EEd0000CAFEsv00000000sd00000000bc⋆sc⋆i⋆
depends:                                                                 
retpoline:        Y
intree:           Y
name:             vboxguest
vermagic:         5.3.15-300.fc31.x86_64 SMP mod_unload
sig_id:           PKCS#7
signer:           Fedora kernel signing key
11
  • "but it does not work" ... What are the symptoms?
    – rickhg12hs
    Commented Dec 18, 2019 at 22:33
  • When I try to install the ISO, I get the message that the virtualbox guest additions are already installed. Instead I should update or remove the guest additions but I do not know how. I tried to install it anyway but I always got the message read-only file system.
    – antimatter
    Commented Dec 19, 2019 at 11:00
  • "The system says that the Virtualbox Guest Additions are already installed..." Why do you think that is false?
    – rickhg12hs
    Commented Dec 19, 2019 at 19:02
  • Because I cannot use the features of the guest additions like better performance.
    – antimatter
    Commented Dec 21, 2019 at 9:59
  • What's the output of lsmod | grep vbox?
    – rickhg12hs
    Commented Dec 22, 2019 at 12:20

1 Answer 1

0

Is your purpose to set full resolution for Silverblue running under Virtualbox? If so, try to set the resolution manually using Gnome settings (Settings->Devices->Displays->Resolution). Worked for me.

5
  • The OP didn't/doesn't seem to have all the VirtualBox kernel modules loaded while running SilverBlue. Which VirtualBox kernel modules do you have loaded?
    – rickhg12hs
    Commented Jan 2, 2020 at 0:20
  • Mine is default install of Silverblue. When I search 'lsmod' for vbox I only get 'vboxguest'. The 'modinfo vboxguest' command gives me almost same output except my kernel is 5.3.16 (5.3.16-300.fc31.x86_64), whereas OP's is 5.3.15 (5.3.15-300.fc31.x86_64).
    – svinoba
    Commented Jan 2, 2020 at 15:44
  • Interesting. I wonder why SilverBlue doesn't load the other vbox kernel modules. If you modprobe -v vboxvideo and modprobe -v vboxsf, do you get all the vbox guest features?
    – rickhg12hs
    Commented Jan 2, 2020 at 16:08
  • Do we need them? My resolution working find with just vboxguest. Anyways, for 'modprobe -v vboxvideo' I get same output as OP's and for 'modprobe -v vboxsf', I get 'Module vboxsf not found in ..." error.
    – svinoba
    Commented Jan 3, 2020 at 13:26
  • "Do we need them? " I suppose that's up to each user to decide. The OP wanted vbox kernel modules for reasons unclear to me.
    – rickhg12hs
    Commented Jan 3, 2020 at 16:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .