0

I have spent many days trying to run a DigitalPersona 4500 fingerprint reader on debian 10 using the vendor sdk in version 2.2.0

I managed to compile the kernel module with some corrections and it seems to be running fine, but when I run the examples they don't find any connected reader

After search a lot I see that the device is loaded with the module xhci_hcd instead of the compiled module, I have tried to force the load using udev rules to continue without being able to succeed

dmesg output:

[ 4602.450705] usb 1-1: new full-speed USB device number 5 using xhci_hcd
[ 4602.607511] usb 1-1: New USB device found, idVendor=05ba, idProduct=000a, bcdDevice= 1.03
[ 4602.607516] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4602.607519] usb 1-1: Product: U.are.U® 4500 Fingerprint Reader
[ 4602.607522] usb 1-1: Manufacturer: DigitalPersona, Inc.
[ 4602.607524] usb 1-1: SerialNumber: {7291B988-67A7-3142-A3C4-01659958B19F}

lsmod | grep dpfp output:

mod_usbdpfp            49152  0
usbcore               294912  3 xhci_hcd,xhci_pci,mod_usbdpfp

it say using by 0

i check the vendor ID and the Device ID in the driver sources and they are ok i check the udev rules, check the udev monitor i dont know what else to do ..

hope someone can help me

Thanks in advance

0

If anybody else have a similar issue the problem is the sdk and the driver itself that is not compatible with the lasts kernels version

the solution is contact with the vendor in this case crossmatch in their site and they can provide you the lastest version of the sdk with no cost

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.