0

I am running latest 64 bit kali linux in VirtualBox and I am not able to find the theharvester.py anywhere

even using locate i cannot find it

and it is installed as when i run the install command i get the following output

root@kali:~# apt-get install theharvester
Reading package lists... Done
Building dependency tree       
Reading state information... Done
theharvester is already the newest version (3.1-0kali2).
theharvester set to manually installed.
The following packages were automatically installed and are no longer required:
  libayatana-ido3-0.4-0 libbfio1
Use 'apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 44 not upgraded.

and when i run theharvester command in terminal i get

root@kali:/usr/share# theharvester
bash: theharvester: command not found
2
  • Did you try the suggestion I linked to in your (now deleted) SO question? It should give you a list of files installed in the apt package, which might help you find the one you need to run
    – DavidW
    Dec 17, 2019 at 11:59
  • Try apropos harvester. Also, locate will not necessarily find what you're looking for. For complete results, use find.
    – Panki
    Dec 17, 2019 at 13:07

3 Answers 3

2

The theHarvester contains an upper case H (GitHub). As filenames are case sensitive on Linux / Kali run theHarvester.

In the past Kali modified the casing to use a lower case h. This was changed recently as can be seen at the git repository from Kalis theHarvester package (theharvester!f2caac3e)

The documentation at has not been updated so far (ref). I've opened an issue theharvester#2. The name change was done because one of theHarvester core devs asked to get it fixed. theharvester#1

0

I used apt-file to search for theharvester.py. It says that it belongs to the package golismero. After install of this package it should be under /usr/share/golismero/plugins/testing/recon/.

0

so you have to do is run the command locate theHarvester

after that look for the directory with tools and then go for that cd to that path /usr/lib/(whatever it says for you) then do ls and find if theHarvester.py exist in it and you're good to go

1
  • 1
    Welcome to the site, and thank you for your contribution. However, please note that the actual problem is the wrong capitalization in the OP's attempt to run the program (which is related to a change in the distribution's naming convention), so your answer doesn't quite address the problem.
    – AdminBee
    Jul 14 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.