0

(Running Debian 10.2 XFCE)

Due to some partition resizing needs, I had to delete my original swap partition and add a new one. I changed the entry in /etc/fstab - swap is recognized and working. I changed the entry in /etc/default/grub - ran update-grub with no errors.

Now, when running the final step - update-initramfs -u - it complains about the old swap UUID not existing. I found a question that was the exact problem I'm having (http://forums.debian.net/viewtopic.php?t=133578), but the fix doesn't work. I'm still getting the Begin: Running /scripts/local-block ... done. message about 15 times, then the boot finally finished.

Once I'm able to login, I find no errors with either dmesg or journalctl. I personally don't care about being able to suspend, so if there's a way to disable this I'm all for it. I did try that (removed the RESUME= entry from /etc/default/grub), but that didn't help either.

/etc/fstab

UUID=40728a0b-10e9-4599-9bb1-1db16e95db8c /boot     ext2    defaults    0 0
UUID=e0fef258-68d0-41b1-9326-dbdc37083000 /         btrfs   subvol=@,defaults,noatime,space_cache,autodefrag    0 1
UUID=e0fef258-68d0-41b1-9326-dbdc37083000 /home     btrfs   subvol=@home,defaults,noatime,space_cache,autodefrag    0 2
UUID=1aea03e4-a509-41c7-8e3e-ad547b34ddd9 swap      swap    defaults,noatime0 2

blkid

/dev/vda1: LABEL="Boot" UUID="40728a0b-10e9-4599-9bb1-1db16e95db8c" TYPE="ext2" PARTUUID="90f85121-01"
/dev/vda2: UUID="e0fef258-68d0-41b1-9326-dbdc37083000" UUID_SUB="84f77425-e0fe-4537-8b2c-b5838f8d70df" TYPE="btrfs" PARTUUID="90f85121-02"
/dev/vda3: UUID="1aea03e4-a509-41c7-8e3e-ad547b34ddd9" TYPE="swap" PARTUUID="90f85121-03"

/etc/default/grub

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='Debian'
GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=1aea03e4-a509-41c7-8e3e-ad547b34ddd9"
GRUB_CMDLINE_LINUX=""
0

Not sure why this was necessary, but the problem was fixed after I ran:

sudo grub-install /dev/vda
sudo reboot

Hopefully this will help someone else in the future.

| improve this answer | |
0

You might want to check /etc/initramfs-tools/conf.d/resume: if it contains a reference to the old swap UUID, you might want to change/remove it from there too, just in case.

Any configuration files in that directory are included in initramfs, so after making any changes, you should run update-initramfs -u.

| improve this answer | |
  • That file didn't exist, so I created it after I made the swap change. Didn't make any difference until I ran grub-install. – ajgringo619 Dec 17 '19 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.