0

My Bluetooth dongle is not working on Linux mint (and other distros). I have tried every possible solution I could get on internet. I even tried different distros based on Arch and ubuntu but no use.

My dongle is very generic and works fine on windows. It does not need any driver or software. I have a few dmesg and other logs, please have a look.

$ dmesg | grep Blue
[  104.529258] Bluetooth: Core ver 2.22
[  104.529285] Bluetooth: HCI device and connection manager initialized
[  104.529293] Bluetooth: HCI socket layer initialized
[  104.529295] Bluetooth: L2CAP socket layer initialized
[  104.529299] Bluetooth: SCO socket layer initialized
[  104.729614] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  104.729616] Bluetooth: BNEP filters: protocol multicast
[  104.729626] Bluetooth: BNEP socket layer initialized
[  106.626960] Bluetooth: hci0: command 0x2003 tx timeout
[  108.674989] Bluetooth: hci0: command 0x2007 tx timeout
[  316.130957] Bluetooth: hci0: command 0x2003 tx timeout
[  318.178971] Bluetooth: hci0: command 0x2007 tx timeout

I have also tried for use blueman instead of blueberry, no use.

$ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

here is another

$ inxi -Fxz
System:    Host: mark85 Kernel: 5.3.0-24-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 
           Desktop: Cinnamon 4.2.4 Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Hewlett-Packard product: HP Compaq dc7900 Small Form Factor v: N/A 
           serial: <filter> 
           Mobo: Hewlett-Packard model: 3031h serial: <filter> BIOS: Hewlett-Packard v: 786G1 v01.27 
           date: 10/22/2015 
CPU:       Topology: Dual Core model: Intel Core2 Duo E8400 bits: 64 type: MCP arch: Penryn rev: A 
           L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 11969 
           Speed: 1995 MHz min/max: 1998/3000 MHz Core speeds (MHz): 1: 1995 2: 1995 
Graphics:  Device-1: Intel 4 Series Integrated Graphics vendor: Hewlett-Packard driver: i915 
           v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1024x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel Q45/Q43 v: 2.1 Mesa 19.0.8 direct render: Yes 
Audio:     Device-1: Intel 82801JD/DO HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.3.0-24-generic 
Network:   Device-1: Intel 82567LM-3 Gigabit Network vendor: Hewlett-Packard driver: e1000e 
           v: 3.2.6-k port: 1100 bus ID: 00:19.0 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Atheros AR9271 802.11n type: USB driver: ath9k_htc bus ID: 1-1:2 
           IF: wlx60e327170563 state: up mac: <filter> 
Drives:    Local Storage: total: 149.05 GiB used: 14.24 GiB (9.6%) 
           ID-1: /dev/sda vendor: Seagate model: ST3160023AS size: 149.05 GiB temp: 21 C 
Partition: ID-1: / size: 18.65 GiB used: 9.01 GiB (48.3%) fs: ext4 dev: /dev/sda3 
           ID-2: /home size: 32.65 GiB used: 5.23 GiB (16.0%) fs: ext4 dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 28.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 199 Uptime: 16m Memory: 3.74 GiB used: 1.56 GiB (41.8%) Init: systemd 
           runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 inxi: 3.0.32 

Yes, my BT is connected, but the output says

$ sudo bluetoothctl
Agent registered
[bluetooth]# show
No default controller available

And

$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 10c4:8108 Cygnal Integrated Products, Inc. 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  • It's a USB dongle? What does lsusb recognise it as? (Please add this to your question, and i will then delete this comment.) – roaima Dec 16 '19 at 7:18
  • Added :) and yes it is a dongle – Ali Hasan Dec 16 '19 at 11:53
-1

The output of dmesg | grep Blue tells you the kernel started its own bluetooth support, not that it has detected your hardware.

The lsusb output shows a VID (vendor id) and PID (product id) that belonged to a dongle that had kernel support in the past.

However, in the current version of the linux kernel, it does not seem to have support.

  • The box of the dongle says it supports Linux, seems like it was a false claim by them. – Ali Hasan Dec 16 '19 at 11:54
  • Ok, with the lsusb output now, it seems this dongle has been kwown to have support in the past. You'll have to dig in the kernel sources (your actual version) to see if it still has support... bugs.launchpad.net/ubuntu/+source/linux/+bug/1221995 – Vincent Achard Dec 16 '19 at 12:31
  • Can I somehow apply the patch on my current system? I have 5.3 kernel, can downgrade to 4.15 or 4.18 as well. – Ali Hasan Dec 16 '19 at 13:55
  • well, I am currently running a 4.16.13 version and in my source kernel file drivers/bluetooth/btusb.c I have a line containing "0x0a12, 0x0001". However, it belongs to an array named 'blacklist_table' which does not sound very good... I'm affraid you're gonna have to downgrade even lower than that... – Vincent Achard Dec 16 '19 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.