0

I am trying to install the spacewalk client packages on CentOS8 server, but its giving below error message. how can I fix this issue?

# dnf install osad
Last metadata expiration check: 0:07:59 ago on Sun 15 Dec 2019 05:52:54 PM EST.
Error:
 Problem: package osad-5.11.109-1.el8.noarch requires python3-osad = 5.11.109-1.el8, but none of the providers can be installed
  - package python3-osad-5.11.109-1.el8.noarch requires python3, but none of the providers can be installed
  - cannot install the best candidate for the job
  - nothing provides python3-setuptools needed by python36-3.6.8-2.module_el8.0.0+33+0a10c0e1.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

update command output

# grep -rH enabled=1 /etc/yum.repos.d/*
/etc/yum.repos.d/CentOS-AppStream.repo:enabled=1
/etc/yum.repos.d/CentOS-Extras.repo:enabled=1
/etc/yum.repos.d/_copr:copr.fedorainfracloud.org:group_spacewalkproject:nightly-client.repo:enabled=1


# yum provides python3-osad
Last metadata expiration check: 2:53:28 ago on Mon 16 Dec 2019 05:16:36 AM EST.
python3-osad-5.11.99-8.module_el8.0.0+43+68a81eb1.noarch : Open Source Architecture Daemon
Repo        : AppStream
Matched from:
Provide    : python3-osad = 5.11.99-8.module_el8.0.0+43+68a81eb1

python3-osad-5.11.109-1.el8.noarch : Open Source Architecture Daemon
Repo        : copr:copr.fedorainfracloud.org:group_spacewalkproject:nightly-client
Matched from:
Provide    : python3-osad = 5.11.109-1.el8

Update 2

error while installing rhn-setup package.

# grep -rH enabled=1 /etc/yum.repos.d/*
/etc/yum.repos.d/CentOS-AppStream.repo:enabled=1
/etc/yum.repos.d/CentOS-Extras.repo:enabled=1


# dnf install rhn-setup
Last metadata expiration check: 1:10:48 ago on Mon 16 Dec 2019 09:24:22 AM EST.
Error:
 Problem: conflicting requests
  - nothing provides usermode >= 1.36 needed by rhn-setup-2.8.16-13.module_el8.0.0+180+337688dc.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

# yum provides rhn-setup
Last metadata expiration check: 1:12:23 ago on Mon 16 Dec 2019 09:24:22 AM EST.
rhn-setup-2.8.16-13.module_el8.0.0+180+337688dc.x86_64 : Configure and register an RHN/Spacewalk client
Repo        : AppStream
Matched from:
Provide    : rhn-setup = 2.8.16-13.module_el8.0.0+180+337688dc

I was missing some repo. after adding those I was able install these

these repos enabled now.

CentOS-AppStream.repo:enabled=1
CentOS-Base.repo:enabled=1
CentOS-Extras.repo:enabled=1
epel.repo:enabled=1
2
  • 2
    Add the output of grep -rH enabled=1 /etc/yum.repos.d/* and yum provides python3-osad to your question. The version of python3-osad for CentOS 8.0 is 5.11.99-8 but yours is trying to install 5.11.109-1. Commented Dec 16, 2019 at 0:29
  • @NasirRiley I added this repo. copr.fedorainfracloud.org/coprs/g/spacewalkproject/… it may be the reason. its getting 5.11.109-1 version.
    – sfgroups
    Commented Dec 16, 2019 at 13:14

1 Answer 1

1

Remove the fedorainfocloud repo. It's meant for Fedora and is pulling a Spacewalk package that isn't compatible with CentOS 8. After removing it:

dnf install osad

1
  • @thanks, removing that one install osad, I have same issue for rhn-setup command. let me update the output
    – sfgroups
    Commented Dec 16, 2019 at 15:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .