0

I have this problem: I live in a university dorm room with an ethernet port because the campus wifi doesn't reach. So, together with the network administrator that was on board with this, I used an openWRT router to create an access point inside my room. It worked for a couple of months until the power went out and now I can't reconnect with the exact same configuration. This is my wpa_supplicant file:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
ap_scan=0
network={
        key_mgmt=IEEE8021X
        eap=PEAP
        pairwise=CCMP TKIP
        identity="myUniEmail"
        password="myUniPassword"
        phase1="peapver=0"
        phase2="auth=MSCHAPV2"
}

And what I get is this:

Successfully initialized wpa_supplicant
eth0.1: Associated with 01:80:c2:00:00:03
WMM AC: Missing IEs
eth0.1: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
eth0.1: CTRL-EVENT-EAP-STARTED EAP authentication started
eth0.1: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
eth0.1: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
eth0.1: CTRL-EVENT-EAP-PEER-CERT depth=0 subject='C=IT, ST=emilia romagna, L=Bologna, O=ALMA MATER STUDIORUM - Università di Bologna, OU=Cesia, CN=almawifi.unibo.it' hash=ce505b0c76f06f20ad7e4cafef889f5e2d098d8e9e6253fdd5d7258c8a579e45
eth0.1: CTRL-EVENT-EAP-PEER-CERT depth=1 subject='C=NL, ST=Noord-Holland, L=Amsterdam, O=TERENA, CN=TERENA SSL CA 3' hash=beb8efe9b1a73c841b375a90e5fff8048848e3a2af66f6c4dd7b938d6fe8c5d8
eth0.1: CTRL-EVENT-EAP-FAILURE EAP authentication failed

Any idea on how can I get this working again? Again, I know for a fact that this configuration worked before and nothing has changed on the network.

  • It seems to be missing anonymous_identity="myUniEmail" – Rui F Ribeiro Dec 15 '19 at 18:46
  • It should also be, I think, password=hash:yyyy where yyyy is echo myUniPassword | tr -d '\n' | iconv -t utf16le | openssl md4 – Rui F Ribeiro Dec 15 '19 at 18:52
  • @RuiFRibeiro I repeat, I haven't done anything like that before and it worked just fine. Also, what do you mean by your first post? – AndreaCRD Dec 15 '19 at 18:52
  • Modifications to the wpa_supplicant file. Test them out. – Rui F Ribeiro Dec 15 '19 at 18:53
  • vi or nano /etc/wpa_supplicant.conf and restarting it. I am mobile right now, won't be able to help further. – Rui F Ribeiro Dec 15 '19 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.