0

So one night I did a full system upgrade with pacman -Syu it upgraded some packages like nvidia, nvidia-utils, mesa, etc. But then after a quick restart the Xorg sesssion was failing to start with an error: (EE) No screens found

After messing around for a while and removing the Xorg config, this was fixed but the screen resolution was broken. I was getting some no gamma detected error (I don't remember what it was). Later, after doing another system upgrade which this time upgraded the linux kernel it was fixed.

BUT THEN the damn audio was all distorted to shit. It was like those ear rape videos on youtube and the volume was stuck at maximum, I had to use an external speaker and reduce the volume from it.

I have no clue wtf is going on here, so I don't know where to even begin with the error logs or whatever. Someone pointed out the nvidia drivers probably died, which maybe yes. I did notice on pulse audio volume control (pav) that the label for the output from the HDMI changed. I tried to downgrade those nvidia drivers but ended up with Xorg errors, it didn't start.

Please help.
Extra details:

Kernel upgraded 5.4.2-arch1-1 => 5.4.3-arch1-1
New nvidia driver version is nvidia-440.44-2
GPU: NVIDIA GTX 1660 Ti

3 Answers 3

3

Trying to fix this issue myself. Downgrading nvidia can resolve the audio issue. But then you'll also have to downgrade your kernel (or at least I did) as your display will break again if you don't. My issue is Steam doesn't work after downgrading. Below is the command that should work to downgrade.
sudo pacman -U /var/cache/pacman/pkg/nvidia-440.36-5-x86_64.pkg.tar.xz /var/cache/pacman/pkg/nvidia-utils-440.36-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/linux-5.4.2.arch1-1-x86_64.pkg.tar.xz

Also, pushing audio out anything other than your GPU should avoid the issue (like headphones directly to the motherboard, at least in my case this works).

1
  • Heyyy! Thanks a lot, this worked for me! Looks like since I didn't downgrade the kernel aswell, I was getting those errors. But now all is back to normal. Hopefully they fix this issue asap. Dec 15, 2019 at 12:00
0

Had the same issue, Workaround is downgrade following packages

nvidia
nvidia-utils
lib32-nvidia-utils
linux
linux-headers
3
  • Yeah this will work too, but as stated in the accepted answer unix.stackexchange.com/a/557329/386409, downgrading nvidia, nvidia-utils and linux is enough and it worked for me. But I don't know if it's necessary to downgrade linux-headers and lib32-nvidia-utils as well. Dec 15, 2019 at 12:02
  • If you want to fix Steam problem then yes, it's necessary.
    – Stan
    Dec 15, 2019 at 23:33
  • I tried downgrading those packages too but steam still didn't start for me. So I used the other method stated in the accepted answer which was to keep everything up to date and use the headphone jack from the motherboard. Everything works perfectly fine now. Dec 16, 2019 at 13:36
0

I use to have the same problem with my video card GTX1060 6GB after upgraded my system.

Luckily I install Nvidia LTS Driver for Arch Linux then it's back to normal if you try this is how to make it.

$ sudo pacman -S nvidia-lts

Then reboot your system after that. Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .