2

I have recently updated to Fedora 31, but I cannot use the "Courier 10 Pitch" font in the system. I have installed the xorg-x11-fonts-Type1 package from dnf, and the fc-list command gives me the correct files used by the font:

$ fc-list | grep Courier
/usr/share/X11/fonts/Type1/c0611bt_.pfb: Courier 10 Pitch:style=Bold Italic
/usr/share/X11/fonts/Type1/c0419bt_.pfb: Courier 10 Pitch:style=Regular
/usr/share/X11/fonts/Type1/c0583bt_.pfb: Courier 10 Pitch:style=Bold
/usr/share/X11/fonts/Type1/c0582bt_.pfb: Courier 10 Pitch:style=Italic
$ 

But if I go to preference setting of gnome-terminal or gedit, I cannot find this font. I also cannot find the font in LibreOffice Writer.

I tried to use a live image, and it is the same result. Why is this happening? Is there a way to fix it?

To reproduce: boot from live image, and: sudo dnf install xorg-x11-fonts-Type1

1 Answer 1

1

As discussed in https://bugzilla.redhat.com/show_bug.cgi?id=1779123, an workaround I am using is converting the font files manually to otf format. Here is the shell script I am using:

for i in {0419,0582,0583,0611}; do
    fontforge -c 'open(argv[1]).generate(argv[2])' \
        /usr/share/X11/fonts/Type1/c${i}bt_.pfb c${i}bt_.otf;
done
sudo mkdir /usr/share/fonts/courier/
sudo mv c{0419,0582,0583,0611}bt_.otf /usr/share/fonts/courier/
sudo fc-cache -v

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .