Possible Duplicate:
How to add write permissions for a group?

When I run Wireshark, It shows the following message:

Couldn't run /usr/sbin/dumpcap in child process: Permission denied
Are you a member of the 'wireshark' group? Try running
'usermod -a -G wireshark _your_username_' as root.

I ran this command: usermod -a -G wireshark myusername and checked my groups using groups myusername and I was added to the wireshark group. But I still get that error message.

[nima@nma ~]$ groups nima
nima : nima wheel dialout wireshark
[nima@nma ~]$ ls -l /usr/sbin/dumpcap 
-rwxr-x--- 1 root wireshark 67884 Aug 16 12:04 /usr/sbin/dumpcap
[nima@nma ~]$ /usr/sbin/dumpcap
-bash: /usr/sbin/dumpcap: Permission denied

What's the problem?


You need to update your group IDs by using newgrp.

  • 3
    This is not what you want to do, that would start a new shell with the real group id set to wireshark, so every file or process you create for instance would be group-owned "wireshark". You want "newgrp" alone or sudo -su "$USER", and in any case, that would only affect the group list of that new shell process and its children. You'd still need to logout to be able to start a new login session with the new group included. – Stéphane Chazelas Nov 14 '12 at 21:16

Did you logout and then login and try the command?

Not the answer you're looking for? Browse other questions tagged or ask your own question.