0

what do I need to do to achieve a nice display output like this from lsblk?

Example for beautiful output

What I currently get is this rather ugly output:

Example for "ugly" output

Thank you very much in advance for your help!

  • 1
    Looks like it's a locale issue. I get same output as yours second with LC_ALL=C environment variable set. Look at your environment, see output of env, maybe you have a sort of LC_* variable set there. Try also LC_ALL=en_US.utf-8 lsblk just for example, your locale may be different than en_US – Sergiy Kolodyazhnyy Dec 14 '19 at 7:55
0

Thanks to @Sergiy Kolodyazhnyy, I found the answer.

It was the locale setting.

After enabling the en_US UTF-8 locale and also setting the environment variable LANG to en_US.UTF-8, lsblk output is just nice!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.