0

I put Kali Linux on a small little laptop for testing and demonstration purposes, but I've run into an issue I've never seen before.

Every wireless interface I plug in through USB shows up as shown in the attached image, it's all mangled up and doesn't actually work, and I've no idea what's wrong!

The interface appears as 'wlx00c0ca97dc12'. Really jumbled up.

Any help would be appreciated, point me in the right direction. Thank you!

Here's my ifconfig:

wlx00c0ca97dc12: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
    ether 2e:a6:a9:c6:0a:fd  txqueuelen 1000  (Ethernet)
    RX packets 0  bytes 0 (0.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 0  bytes 0 (0.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lsusb, it's device 11:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 006: ID 8087:0a2a Intel Corp. UB91C
Bus 001 Device 005: ID 04f3:2052 Elan Microelectronics Corp. 
Bus 001 Device 003: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 002: ID 1bcf:2c80 Sunplus Innovation Technology Inc. Lenovo EasyCamera
Bus 001 Device 011: ID 0cf3:9271 Qualcomm Atheros Communications AR9271 802.11n
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And iwconfig:

wlx00c0ca97dc12  IEEE 802.11  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off 

Hopefully, that's enough information, I can post more if needed.

Edited for further clarification:

While editing this, Hooray! I managed to get it working. The long ass interface names were the issue. I took mosvy's advice and returned the interface naming scheme back to normal. I can now connect just fine through my dongle :)

touch /etc/udev/rules.d/80-net-setup-link.rules Fixed it for me!

I was expecting a more usual interface name like eth1, eth2, etc. I assumed that this messed up version of the interface name meant something was wrong, as I'm unable to connect to an access point using the USB Wireless Devices that I plug into the machine. For example, I plug in my Alfa Wireless USB dongle and it won't allow me to connect to any AP's, and I receive a system message saying "activation of network connection failed".

I thought it may have been a driver issue, but installing Kali Wireless drivers yielded no results. If these names are accurate as they're the naming conventions used in Kali and not actually an error, then I must be looking at a different kind of issue.

2
  • In what way doesn't the device as named not work? Please edit your question to provide concrete facts to support this. – roaima Dec 14 '19 at 0:36
  • You'll have to get used to it. That's the modern way to name interfaces in linux ;-) (google for "predictable interface names" -- "predictable": at least they haven't lost their sense of humor). If your system works like mine, you can restore the old-style naming (wlan0, eth0, usb0, etc) by creating an empty udev rule in /etc which overrides the one from /lib: touch /etc/udev/rules.d/80-net-setup-link.rules. – mosvy Dec 14 '19 at 1:26
0

touch /etc/udev/rules.d/80-net-setup-link.rules Fixed it for me! New Interface naming conventions were the issue, reverting to the old ones fixed it. Thanks to mosvy :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.