0

I'm trying to use make to install a package in my LAMMPS build. When I run the command make -lib-gpu args="-b" I get the result:

/usr/bin/ld: cannot find -lcuda

And makefails. When I run ld -lcuda --verbose I get:

attempt to open //usr/x86_64-redhat-linux/lib64/libcuda.so failed
attempt to open //usr/x86_64-redhat-linux/lib64/libcuda.a failed
attempt to open //usr/lib64/libcuda.so succeeded
-lcuda (//usr/lib64/libcuda.so)
libm.so.6 needed by //usr/lib64/libcuda.so
found libm.so.6 at //usr/lib64/libm.so.6
libc.so.6 needed by //usr/lib64/libcuda.so
found libc.so.6 at //usr/lib64/libc.so.6
libdl.so.2 needed by //usr/lib64/libcuda.so
found libdl.so.2 at //usr/lib64/libdl.so.2
libpthread.so.0 needed by //usr/lib64/libcuda.so
found libpthread.so.0 at //usr/lib64/libpthread.so.0
librt.so.1 needed by //usr/lib64/libcuda.so
found librt.so.1 at //usr/lib64/librt.so.1
libnvidia-fatbinaryloader.so.418.39 needed by //usr/lib64/libcuda.so
found libnvidia-fatbinaryloader.so.418.39 at //usr/lib64/libnvidia-fatbinaryloader.so.418.39
ld-linux-x86-64.so.2 needed by //usr/lib64/libm.so.6
found ld-linux-x86-64.so.2 at //usr/lib64/ld-linux-x86-64.so.2
ld: warning: cannot find entry symbol _start; not setting start address

It appears that ld is able to find -lcuda (at least I think that is what this means), so why isn't it doing the same in the make command?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.