1

I'm trying to access the scanner functionality of some Ricoh All-in-One printers from a workstation with Debian Stretch using Vuescan, but none of the means I've used can find any of them: neither scanimage nor sane-find-scanner detect them even with the net backend enable from conf files; simple-scan, xsane and VueScan either show an error message telling me there are no scanners available or lock and the avahi-daemon can't detect any _scanner._tcp or _uscan._tcp services. However the printing function works without any issue in all of them.

I used Wireshark to try and findout what is happening, and for VueScan the mDNS queries with the questions about available services aren't fully answered (it asks for both printer and scanner services, but the mDNS responses only show answers for printer services).

Wireshark Screenshot

I can tell its not an issue with the scanners themselves as they work normally when operated manually and I don't think its a firewall issue as I have both wiped clean its connection rules and added rules that should allow communication from and to the machines from any port and the end result was the same (no scanning from PC). I even tried connecting my workstation with one of them directly, but still nothing.

I've talked with VueScan's customer service but the last thing they could think of was a problem or changes in the machines' front panel or firmware.

How can I get Vuescan to find and use the scanners?

  • What is the model? Have you try with other OS? – Romeo Ninov Dec 12 '19 at 17:10
  • The model I'm currently making tests is the MP 305+. I have also tried in Windows 10, but the same happened – JORGE Dec 12 '19 at 19:12
  • AFAIK to manage it you need TWAIN driver (work in Windows). You can also configure it store scanned image in SMB share (only one) – Romeo Ninov Dec 12 '19 at 19:31
  • 1
    Edited post for clarity. Also I set up the share and it works, meaning communication from the Ricoh All-inOne to the workstation works as intended. However, I still haven't find out what is blocking my workstation to send commands to the machine to initiate scans – JORGE Dec 13 '19 at 22:19
  • 1
    Not yet. I've submitted an inquiry so I'll have to wait. I have contacted Vuescan's customar support and the last thing they told me is that Vuescan only works with machines that support Airprint/Airsacn/eSCL. That would mean most of the machines I'm working with won't work no matter what (only a couple show Airprint capabilities), yet disabling and anabling Airprint also did nothing for the _scanner and _uscan services to be published... – JORGE Dec 18 '19 at 13:45
0

In the end it really was about a matter of the MFPs having or not airprint capabilities. While one of them does have Airprint though it's not detected (workmate says that specific MFP has been configured a lot), the other MFPs I was using didn't have that. Once a couple of MFPs with Airprint that haven't been tinkered with were connected, VueScan detected them inmediately.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.