1

I've attempted to raise my wireless interface using ip link set wlp2s2 up and it is not raising. I'm running arch linux 32 on an IBM thinkpad r51 with an Intel PRO/Wireless 2200BG wireless card. I have the proper driver installed and enabled and I can discover wifi networks but when I try to connect to them it loops the authentication process. output of dmesg -T | grep -i wlp2s2:

[Thu Dec 12 15:50:54 2019] ipw2200 0000:02:02.0 wlp2s2: renamed from eth0
[Thu Dec 12 15:51:06 2019] wlp2s2: Setting MAC to ee:96:e1:64:55:e9
[Thu Dec 12 15:52:32 2019] wlp2s2: Setting MAC to 00:0e:35:35:c9:39
[Thu Dec 12 15:52:33 2019] wlp2s2: Setting MAC to 2e:58:85:6c:fc:3c
[Thu Dec 12 15:53:39 2019] wlp2s2: Setting MAC to 1e:0a:0d:c0:04:ec
[Thu Dec 12 15:55:39 2019] wlp2s2: Setting MAC to 12:1e:7d:8c:5c:32
[Thu Dec 12 16:00:58 2019] wlp2s2: Setting MAC to ce:ec:55:26:38:a0

ouput of journalctl -f:

-- Logs begin at Wed 2019-12-11 15:49:28 UTC. --
Dec 12 16:43:25 mikael NetworkManager[318]: <warn>  [1576169005.9104] device (wlp2s2): no secrets: User canceled the secrets request.
Dec 12 16:43:25 mikael NetworkManager[318]: <info>  [1576169005.9105] device (wlp2s2): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Dec 12 16:43:25 mikael NetworkManager[318]: <info>  [1576169005.9251] manager: NetworkManager state is now DISCONNECTED
Dec 12 16:43:25 mikael NetworkManager[318]: <warn>  [1576169005.9460] device (wlp2s2): Activation: failed for connection 'Uniblab'
Dec 12 16:43:25 mikael NetworkManager[318]: <info>  [1576169005.9536] device (wlp2s2): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Dec 12 16:43:25 mikael kernel: wlp2s2: Setting MAC to ae:dc:84:9c:76:97
Dec 12 16:43:26 mikael NetworkManager[318]: <warn>  [1576169006.0710] device (wlp2s2): set-hw-addr: new MAC address AE:DC:84:9C:76:97 not successfully set (scanning)
Dec 12 16:43:26 mikael NetworkManager[318]: <info>  [1576169006.1905] device (wlp2s2): supplicant interface state: inactive -> disabled
Dec 12 16:43:26 mikael NetworkManager[318]: <info>  [1576169006.2434] device (wlp2s2): supplicant interface state: disabled -> inactive
Dec 12 16:43:26 mikael wpa_supplicant[333]: wlp2s2: Reject scan trigger since one is already pending

output of ifconfig

wlp2s2: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether aa:89:89:1b:00:46  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Any tips or clues would be greatly appreciated

3
  • may you show us the output od rfkill list to see if your device is maybe soft blocked and of ifconfig to see the flags of your device?
    – derwana
    Dec 14, 2019 at 16:40
  • rfkill list shows that it is neither soft blocked nor hard blocked and I've appended the output of ifconfig to the post.
    – MichaelPV
    Dec 15, 2019 at 21:54
  • your wlp2s2 is up but not running; do you use a network manager and if yes which one?
    – derwana
    Dec 18, 2019 at 9:10

2 Answers 2

1

Given the two following lines:

Dec 12 16:43:25 mikael NetworkManager[318]: <warn>  [1576169005.9104] device (wlp2s2): no secrets: User canceled the secrets request.
Dec 12 16:43:25 mikael NetworkManager[318]: <info>  [1576169005.9105] device (wlp2s2): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')

I would tell that the network you're trying to connect to isn't an open one and you didn't configured any authentication for it in wpa-supplicant configuration file.

For ip to be successful, the underlying layers (aka 802.<whatever>) should be working. So, the steps are:

  1. Configure the good secrets for wpa-supplicant.
  2. Launch wpa-supplicant.
  3. Up your interface.
0

I actually had the same problem with my headless nas laptop and I learned the following:

If you have a WPA/WPA2 password/string it is not enough/not working to pass it over through the accesspoint/router blank via terminal for many, but mainly security reasons.

1. You have to generate an encryption key out of the password and you can do it via wpa-supplicant f.e. with wpa_passphrase your-ESSID your-wifi-passphrase | sudo tee /etc/wpa_supplicant.confas describesudo pacman -S NetworkManagerd here or here and works on arch linux exact the same way. Btw. it doesn't matter where you store your wpa-supplicant file - just remember the path to it. binarym also told you the basic structure in his answer. (the generated wpa-supplicant key, not the wpa password itself is what is needed in the arch wiki)


  1. If you got Internet connected f.e. via LAN cable you can sudo pacman -S wifi-menu and than execute wifi-menu that is the fastest way I found to connect to a password protected wifi from terminal and generate a wpa_supplicant key out of a password. It might be already installed.

  1. The best way to connect via terminal via netctl because it is the most transparent way to connect to the wifi I found here, described as "the hard way" but as I found the most logical way and most easy to handle as follows and it should be already installed:

a) check the example folder with ls /etc/netctl/examples

b) select one example profile that works for you and copy it to the netctl folder, in your case:

sudo cp /etc/netctl/examples/wireless-wpa /etc/netctl/your_profile_name

or

sudo cp /etc/netctl/examples/wireless-wpa-static /etc/netctl/your_static_profile_name - if you want a static ip address.

c) Edit your profile f.e. with vim or nano /etc/netctl/your_profile_name, add your password - blank or key by uncommenting what you need and save it with ctrl + x or at vim with :wq

d) and than just netctl start your_profile_name - or stop it with netctl stop your_profile_name or to autostart it with netctl enable your profile_name - as simple as that. (you may have to install netctl with sudo pacman -S netctl)


4. If you decide to use/install a graphical interface like gnome you can use NetworkManager (sudo pacman -S NetworkManager).

I think my first two answers should already solve your issue - the others are more out of convenience because I personally like them more because I can remember them more easily.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .