0

I am rebuilding the Linux kernel, version 5.3.9, for my board Cubieboard 2 (Allwinner A20 SoC Armbian disty). When I enable the option CONFIG_KPROBES and rebuild the kernel, I get an exception ("Oops") with this debug info during loading:

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
Loading, please wait...
starting version 232
[    4.290741][  T204] Internal error: Oops: 5 [#1] SMP THUMB2
[    4.296333][  T204] Modules linked in: pinctrl_axp209(+)
[    4.301661][  T204] CPU: 1 PID: 204 Comm: systemd-udevd Not tainted 5.3.9-sunxi #174
[    4.309403][  T204] Hardware name: Allwinner sun7i (A20) Family
[    4.315338][  T204] PC is at load_module+0x1646/0x1a44
[    4.320484][  T204] LR is at load_module+0x1635/0x1a44
[    4.325624][  T204] pc : [<c018d506>]    lr : [<c018d4f5>]    psr: 300f0033
[    4.332583][  T204] sp : ee2b9e40  ip : ffc00000  fp : c0f04d48
[    4.338502][  T204] r10: 00000000  r9 : bf802080  r8 : bf80208c
[    4.344421][  T204] r7 : ee2a56a8  r6 : 00000008  r5 : 7f002881  r4 : ee2b9f38
[    4.351642][  T204] r3 : 7f002889  r2 : bf802290  r1 : 00000000  r0 : c0f13c04
[    4.358865][  T204] Flags: nzCV  IRQs on  FIQs on  Mode SVC_32  ISA Thumb  Segment none
[    4.366867][  T204] Control: 50c5387d  Table: 6e2bc06a  DAC: 00000051
[    4.373308][  T204] Process systemd-udevd (pid: 204, stack limit = 0x(ptrval))
[    4.380529][  T204] Stack: (0xee2b9e40 to 0xee2ba000)
[    4.385608][  T204] 9e40: bf80208c 00007fff bf802080 c018b459 00000001 bf8020c8 b6eecbb8 bf802194
[    4.394510][  T204] 9e60: c0b99548 bf806e83 bf802290 bf806000 c0b99494 c0b994a0 c0b994f8 c0f04d48
[    4.403392][  T204] 9e80: ee2b8000 bf000000 00000000 ee2b9eb8 00002be4 c025baa3 00000000 00000000
[    4.412265][  T204] 9ea0: 00000000 00000000 00000000 00000000 6e72656b 00006c65 00000000 00000000
[    4.421139][  T204] 9ec0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[    4.430018][  T204] 9ee0: 00000000 00000000 00000000 033d4d7b 7fffffff c0f04d48 00000000 f0f47000
[    4.438898][  T204] 9f00: b6eecbb8 c0101224 ee2b8000 0000017b 0157ca00 c018da85 7fffffff 00000000
[    4.447778][  T204] 9f20: 00000003 c093dbb1 ffffe000 f0f47000 00002be4 00000000 f0f47bbb f0f47dc0
[    4.456655][  T204] 9f40: f0f47000 00002be4 f0f4961c f0f494ac f0f488e0 00003000 00003170 00001e24
[    4.465534][  T204] 9f60: 0000330b 00000000 00000000 00000000 00001e14 00000022 00000023 0000001a
[    4.474413][  T204] 9f80: 00000000 00000014 00000000 033d4d7b 00000000 0157ca00 0157b298 f00b8800
[    4.483293][  T204] 9fa0: 0000017b c0101001 0157ca00 0157b298 00000005 b6eecbb8 00000000 b6eed398
[    4.492171][  T204] 9fc0: 0157ca00 0157b298 f00b8800 0000017b 00020000 004563cc 00000000 0157ca00
[    4.501049][  T204] 9fe0: bee4f748 bee4f738 b6ee6aeb b6df71c2 600f0030 00000005 00000000 00000000
[    4.509952][  T204] [<c018d506>] (load_module) from [<c018da85>] (sys_finit_module+0x6d/0x88)
[    4.518497][  T204] [<c018da85>] (sys_finit_module) from [<c0101001>] (ret_fast_syscall+0x1/0x62)
[    4.527374][  T204] Exception stack(0xee2b9fa8 to 0xee2b9ff0)
[    4.533127][  T204] 9fa0:                   0157ca00 0157b298 00000005 b6eecbb8 00000000 b6eed398
[    4.542007][  T204] 9fc0: 0157ca00 0157b298 f00b8800 0000017b 00020000 004563cc 00000000 0157ca00
[    4.550884][  T204] 9fe0: bee4f748 bee4f738 b6ee6aeb b6df71c2
[    4.556643][  T204] Code: 0308 429a f000 80cb (696b) 4642 
[    4.562287][  T204] ---[ end trace 9274c7d1a19d7530 ]---
Begin: Loading essential drivers ... done.

Without this options, the kernel loads and works fine. What am I doing wrong?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.