I manage an apt repository, for package
PACKAGE, which has dependency
DEPENDENCY are available in my repository.
We just released a version of
DEPENDENCY (version 4.0.0), and now installing the same
PACKAGE on a completely clean machine fails with the error:
The following packages have unmet dependencies: PACKAGE : Depends: DEPENDENCY (< 1.2.0) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
If I check the versions of DEPENDENCY available, I can see that there are known packages which meet the
<< 1.2 requirement:
sudo apt list -a DEPENDENCY Listing... Done DEPENDENCY/stable 4.0.0 all DEPENDENCY/stable 1.1.12 all DEPENDENCY/stable 1.1.11 all DEPENDENCY/stable 1.1.10 all ...
Since I actually manage the package AND the dependency I can fix this on the repository side, but how? Why doesn't
apt recognise the correct dependencies?
apt --fix-broken won't work because the packages are somehow broken on the server side).