1

I've been experiencing an issue with a RHEL 7 Server in which relatively newly created Active Directory domain users can't connect to the server.

When I try to login with users which were created earlier it works just fine, but when I try to log in with users which were created relatively late or even with the ones I created especially for the experiment, it doesn't work.

When I run the id command for such users, the output states that the user doesn't exist.

I tried to delete the sssd cache and also disable caching but nothing seems to work.

Does anyone know what to do in such situations?

  • By "domain" you mean AD? Do they have all the required attributed in AD or is SSSD configured to generate it? -> access.redhat.com/documentation/en-us/red_hat_enterprise_linux/… – pbm Dec 11 '19 at 14:05
  • Yes, I do mean AD! – SystemKing Dec 11 '19 at 14:19
  • 1
    Without knowing your configuration this is just going to be guesswork – roaima Dec 11 '19 at 15:56
  • How did you join to the domain? Are the nameservers still correct (pointing to the AD servers, not externally)? What do the logs tell you when you try to look up a username? What is the sssd.conf configuration? Have you got sensible values in nsswitch.conf? Please give an example of how you're checking a user does and doesn't exist. – roaima Dec 15 '19 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.