1

I have MySQL 5.5 installed via packages.dotdeb.org. When trying to update 5.1, which is also installed, I get the following error:

E: /var/cache/apt/archives/mysql-client-core-5.1_5.1.66-0ubuntu0.11.10.2_amd64.deb: trying to overwrite '/usr/share/man/man1/mysqlcheck.1.gz', which is also in package mysql-client-core-5.5 5.5.28-1~dotdeb.0

I'm unsure how to proceed. I installed 5.1 before learning how to get more up-to-date packages in Mint's update/package manager. I don't want to keep 5.1 since I do have 5.5, but I'm concerned that removing it via apt will mess up my 5.5 installation. Can I safely remove 5.1? If not, how should I proceed?

1

From what it looks like, you have MySQL 5.5 installed...which is newer than MySQL 5.1 That is probably part of your problem. If you want to replace 5.5 with 5.1 (and downgrade) then you should remove 5.5 completely first, and then install 5.1. You should never mix MySQL versions in a local install without using a different install prefix. It can lead to dependency issues (linking in the wrong code, loading the wrong library, etc). [Or maybe I don't completely understand]

  • Well, like I said in the question, I want to remove 5.1 entirely and keep 5.5. So, not a downgrade, but rather a removal of the old. – Major Productions Nov 14 '12 at 4:16
  • Then you will likely need to remove both and start fresh. – sparticvs Nov 14 '12 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.