4

I updated recently to fedora 31 and lost menu bar in gnome-terminal.

I can enable menu bar for a single terminal session by right mouse press->enable menu bar. But there is no option to enable it permanently.

I already found: Gnome Help

But there is no option Show menubar by default in new terminals. as described in the help. On older installation I see the entry as the first item in the window which I attached a screen shot. config window

Which config file stores the terminal config? Can it be edit by hand?

2

The problem was that a more general setting was colliding with the application specific setting. No idea why a specific setting can never override a global setting as in nearly all other options for gnome, but this is another discussion...

OK, the solution was:

start dconf-editor, go to org.gnome.Terminal.Legacy.Settings:headerbar and set the value to false. The gnome-shell must be restarted to let the new setting take effect! No idea why this is the case, but all these options are looking curious to me.

Now you can edit with right click inside a gnome-terminal session, go to Preferences->General and select "Show menubar by default in new terminals" This menu was not visible before! This option works immediately. Not another reboot needed :-)

There is no hint in the docs for now! So I leave this answer if someone else runs in the same trouble.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.