1

I have more than one desktop computer running Arch Linux KDE. All were initially configured the same. Now one of them now has a scaled up display. I have not found the setting that is responsible for this.

Having checked every setting in KDE, I can say it is not a setting within KDE. Which other settings or config files could be making font (and other display elements) too large?

The text of messages during boot is normal. The problem starts once X starts.

My monitor has 109 ppi. The problem is shown here:

xdpyinfo | grep dots
resolution:    192x191 dots per inch

I would like that value to be either 109 (to match monitor) or 96 (the usual Xorg value).

In System Settings > Display Configuration, the scale factor is 1.0.

In System Settings > Fonts I can check "Force font DPI" and set my desired value, but it doesn't have any effect. xdpyinfo still reports "192x191 dots per inch".

I do not have any Xorg config files:

/etc/xorg.conf: No such file or directory
/etc/X11/xorg.conf: No such file or directory

I do not have anything unusual in .fonts.conf:

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
<dir>~/.fonts</dir>
<match target="font">
<edit mode="assign" name="hinting">
<bool>true</bool>
</edit>
</match>
<match target="font">
<edit mode="assign" name="hintstyle">
<const>hintfull</const>
</edit>
</match>
<match target="font">
<edit mode="assign" name="antialias">
<bool>true</bool>
</edit>
</match>
</fontconfig>

I do not find any unusual settings from printenv either.

1

Reading the ArchWiki for Xorg led me to the solution. It states

The DPI of the X server is determined in the following manner:

  • The -dpi command line option has highest priority.
  • If this is not used, the DisplaySize setting in the X config file is used to derive the DPI, given the screen resolution.
  • If no DisplaySize is given, the monitor size values from DDC are used to derive the DPI, given the screen resolution.
  • If DDC does not specify a size, 75 DPI is used by default.

Based on that, I looked for "-dpi" and I found the problem with this:

grep -r '\-dpi' /etc/
/etc/sddm.conf:ServerArguments=-nolisten tcp -dpi 192

Removing "-dpi 192" from that line solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.