2

This is related to a question I asked about 3 years ago. Since then things have changed a bit apparently. One of the obvious ones is that aptitude itself has changed from whatever version it was to aptitude 0.8.12 or to be more precise -

$ aptitude --version
aptitude 0.8.12
Compiler: g++ 9.2.1 20190821
Compiled against:
  apt version 5.0.2
  NCurses version 6.1
  libsigc++ version: 2.10.1
  Gtk+ support disabled.
  Qt support disabled.

Current library versions:
  NCurses version: ncurses 6.1.20191019
  cwidget version: 0.5.18
  Apt version: 5.0.2

The other thing which has changed is aptitude has its documentation in aptitude-doc-en and the point/documentation I am interested is located in -

file:///usr/share/doc/aptitude/html/en/ch02s05s05.html

where it says -

Option: Aptitude::CmdLine::Verbose
Default: 0
Description: This controls how verbose the command-line mode of aptitude is. Every occurrence of the -v command-line option adds 1 to

this value.

Now the configuration file is supposed to be in one of the three places and I chose and made a 3-4 lines at

$ cat ~/.aptitude/config
Aptitude "";
Aptitude::CmdLine "";
Aptitude::CmdLine::Verbose "2";

Now I don't know if this is good enough or not. I tried the following commands -

$ sudo apt update 

and

$ sudo aptitude update 

But neither gave me any more output. Am I doing something wrong ?

2

Regarding the verbosity setting, your configuration is correct (but you only need the last line). However, apt update doesn’t use Aptitude’s settings, so you won’t see a difference there. The difference with aptitude update is minor, it adds a status line at the end, showing the number of upgradable packages etc.

To check verbosity settings, the best command is aptitude moo: it shows a different message for each verbosity setting up to 6.

  • Thanks, even I (as current package maintainer of aptitude) wasn't aware of that "easter egg". :-D I'd though get a different message for each verbosity setting up to "6": See aptitude -vvvvv moo vs aptitude -vvvvvv moo. Additionally, more or less confirming shirish's findings, aptitude -o Aptitude::CmdLine::Verbose=<n> moo doesn't work, it always gives me There are no Easter Eggs in this program.. – Axel Beckert Dec 9 '19 at 10:30
  • 1
    @Axel ah yes, up to 6, indeed. aptitude -o ignores the setting for me too, but setting it in the configuration file works... – Stephen Kitt Dec 9 '19 at 10:38
  • The latter definitely sounds like a (IMHO minor, but still a) bug. Thanks for pointing this out! – Axel Beckert Dec 9 '19 at 10:40
2

Aptitude::CmdLine::Verbose "2";

[…]

$ sudo aptitude update

But neither gave me any more output.

For me, there is more output (to be precise one more line at the end) with either your example config or an additional -v, for example in a pbuilder Debian sid chroot with aptitude 0.8.12-1:

# aptitude update
Hit http://debian.ethz.ch/debian sid InRelease

# aptitude -v update
Hit http://debian.ethz.ch/debian sid InRelease

Current status: 0 (+0) broken, 0 (+0) upgradable, 17358 (+0) new.
# echo 'Aptitude::CmdLine::Verbose "2";' >> .aptitude/config
# aptitude update
Hit http://debian.ethz.ch/debian sid InRelease

Current status: 0 (+0) broken, 0 (+0) upgradable, 17358 (+0) new.
#

Please note that with increased verbosity, aptitude also outputs package statistic differences.

However, this seems to be a bug, as aptitude is expected to output these statistics, too, but doesn't:

# aptitude -o Aptitude::CmdLine::Verbose=2 update
Hit http://debian.ethz.ch/debian sid InRelease

#

I reported this as bug to Debian. Thanks for bringing up this topic.

JFTR: I can also reproduce this (only tested -v vs -o Aptitude::CmdLine::Verbose=2) on Debian 10 Buster with aptitude 0.8.11-7, on Debian 9 Stretch with aptitude 0.8.7-1, and Debian 8 Jessie with aptitude 0.6.11-1+b1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.