0

EDIT 1 and temporary solution:

This story is a kind of joke as everybody says it's not me it's the other one. Anyway... after looking everywhere.

  • Found a guy who had this issue with another card under windows, the manufacturer replaced the card telling the fan sensor chip was broken
  • On an old post I opened on nvidia devtalk, a guy said the driver dos not interfere with fans, therefore it's a hardware issue. This makes me laugh a bit as as soon as you reload the machine with an non-nvidia opensource driver, the fan stops it's yoyo
  • I have a 2nd exact same machine (hardware, os,drivers, all) where the fan speed is consistent

The solution I found for the moment is to kick out the original fan and replace it with a classic 80mm fan I attached with screws. We ran a heavy cuda job on it and the fan keeps the card under 60°C when it climbs to 80°C with the original cooling system.

Original post:

I have a couple of machines running

  • debian 10 (last update)
  • xfce4
  • lightdm

Those machines are running nvidia cards like GTX970.

I installed nvidia-driver from debian repo and the card is working well. The only problem is on some machines, the graphic card fan speed up to maximum speed every 4 seconds and for 1 sec only. It's pretty annoying as it makes this yoyo without reason and even if the GPU is cold less than 30°C.

I already tried some coolBits settings and tricks but can't find a solution to calm down the fan or at least make it rotate constantly and not like a yoyo.

EDIT 1:

I tried again to add this CoolBits setting in xorg.conf. I have now a Fan setting in nvidia control panel but when I change it, it still do the yoyo, except at 100% where the fan rotate like crazy

1 Answer 1

0

I found myself in the exact same situation with my 960 card on Linux Mint 19. I run the following command at startup, and the fan speed never changes:

/usr/bin/nvidia-settings -a [gpu:0]/GPUFanControlState=1 -a [fan-0]/GPUTargetFanSpeed=60

Now, the only thing that I use that really stresses my GPU is the Folding@Home client and QEMU VMs. But so far, I have not seen the fan speed (≈2075 RPM) or temp (≈60°) change.

2
  • tried too, it doesn't fix the issue. I removed the nvidia driver and boot with "nouveau" and the fan yoyo stopped. :-/ do nvidia care about this kind of things if we ask for a fix?
    – darxmurf
    Dec 9, 2019 at 8:41
  • Maybe ask on their Dev forum. The only other thing I can think of is to try a different driver version (I use the 440 series). Dec 9, 2019 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .