Today I tried to get Live Kali Linux working off a USB stick. When I got to the login screen, I tried entering root as the username and toor as the password like always, but the login failed. I am out of ideas, since the official Kali site still says those should be the correct login credentials.

Here are the steps for reproducing on my Lenovo y700 laptop:

  1. Download a Kali linux iso image from the official website. I tried 32-bit and 64-bit versions of the latest Kali Linux and I also tried an old 2018 image, all with the same results

  2. Burn the image onto a flash drive. For this I tried using Rufus, Etcher and the dd tool from Linux. I followed the instructions on the official website.

  3. Plug the USB into the computer, choose "Legacy Mode" from BIOS boot screen (because if I choose UEFI, then even if USB boot is enabled, it says usb boot is disabled in uefi settings). When the grub screen comes up, I can choose either kali or "advanced options". There is no option for installation.

  4. Choose the live version and it will boot into a login screen. Enter root as the username and toor as the password, and get invalid credentials as the response

  • 1
    1. Are you sure you downloaded the correct image from the correct website? 2. Did you check the hash to verify the integrity of the file? – Zwans Dec 5 '19 at 13:45

I don’t know if you still need this, but to anyone who does, Kali changed the password structure from root/toor to kali/kali. This was driving me crazy as it was always root/toor before.

See: https://www.kali.org/news/kali-default-non-root-user/


Username: Kali Password: Kali

read more here https://www.kali.org/news/kali-default-non-root-user/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.