1

I'm running Cinnamon on a Devuan GNU/Linux 3 (Beowulf) machine - which is essentially the same as Debian 10 (Buster).

My distribution uses the wicd daemon for network connection management; and I have an applet on my panel. But - an applet for NetworkManager is also present, even though I don't need it. I tried to get rid of it, but couldn't figure out how. Haven't found where its presence is configured, and it also doesn't seem to be its own separate process which I could avoid having run.

What can I do to get rid of the applet?

enter image description here
Don't want: NetworkManager, The applet to the right of the "US".
Want to keep: wicd, The applet to the left of the clock.

1

Solutions as presented by Archwiki - this is a mere recitation.


In short the nm-applet package cannot be removed as it is essential part of cinnamon but you can suppress loading it by creating a custom cinnamon configuration.

cp /etc/xdg/autostart/nm-applet.desktop ~/.config/autostart/nm-applet.desktop

And append the line

X-GNOME-Autostart-enabled=false

Alternatively block it by overriding the command itself:

ln -s /bin/true /usr/local/bin/nm-applet

Notably usr/local/bin of course must precede the standard location of nm-applet in the PATH in this case.

| improve this answer | |
  • The link suggestion depends on your path seeing /usr/local/bin before the actual applet executable and might be prone to error. – Thomas N Dec 5 '19 at 15:05
  • I agree, but it should be common practice to put local and user-defined settings so that they override global/system-wide/default settings. Otherwise the whole idea of adjusting systems to user preferences and local needs would be corrupted. – Fiximan Dec 5 '19 at 15:17
0

Why don't you just disable the network-manager service if you rely on wicd, and simply disable the autostart of nm-applet with:

$ sudo systemctl disable network-manager.service 
$ sudo echo "Hidden=true" >> /etc/xdg/autostart/nm-applet.desktop 

You can also check your autostart configuration for .desktop files with dex in dry mode (you may need to sudo apt install dex first)

$ dex -ad 

...
Executing command: gsettings-data-convert
Executing command: light-locker --late-locking
Executing command: /usr/lib/gnome-settings-daemon/gsd-a11y-settings
Executing command: /usr/lib/gnome-settings-daemon/gsd-color
Executing command: /usr/lib/gnome-settings-daemon/gsd-datetime
Executing command: /usr/lib/gnome-disk-utility/gsd-disk-utility-notify
Executing command: /usr/lib/gnome-settings-daemon/gsd-housekeeping
Executing command: /usr/lib/gnome-settings-daemon/gsd-keyboard
Executing command: /usr/lib/gnome-settings-daemon/gsd-media-keys
Executing command: /usr/lib/gnome-settings-daemon/gsd-power
Executing command: /usr/lib/gnome-settings-daemon/gsd-print-notifications
Executing command: /usr/lib/gnome-settings-daemon/gsd-rfkill
Executing command: /usr/lib/gnome-settings-daemon/gsd-screensaver-proxy
Executing command: /usr/lib/gnome-settings-daemon/gsd-sharing
Executing command: /usr/lib/gnome-settings-daemon/gsd-smartcard
Executing command: /usr/lib/gnome-settings-daemon/gsd-sound
Executing command: /usr/lib/gnome-settings-daemon/gsd-wacom
Executing command: /usr/lib/gnome-settings-daemon/gsd-wwan
Executing command: /usr/lib/gnome-settings-daemon/gsd-xsettings
...

Unless you are proficient in configuring your wifi connection - including edits to the wpa_supplicant.conf for key-mgmt - from the terminal, you should definitely not mess with the network-manager's GUI wrapper nm-applet executable itself in /usr , because if for some reason your installation of wicd happens to break (user-error, accidentally, bug in an update etc.) you will still have all of your network-manager package files, including nm-applet GUI as a fallback, allowing you to apt update && apt [install/upgrade/full-upgrade]

| improve this answer | |
  • The service is disabled. I'll try your suggestion regarding the use of Hidden. – einpoklum Dec 5 '19 at 14:22
  • One other important point: while systemctl disable network-manager.service disables the service (removes its symlinks hence no automatic start at boot) it does not prevent the network-manager.service from being reactivated either manually or by some system process with appropriate permissions. If you rely on wicd completely, you may want to systemctl mask network-manager.service instead which both disables and hides the service preventing any type of start while it is masked. – BarBar1234 Dec 5 '19 at 20:08
  • systemctl? Is that a systemd thing? I don't use that abomination, thank you very much - and neither should you! :-) – einpoklum Dec 5 '19 at 20:10
  • Sorry, I'm confused now because you stated that your system is essentially a Debian 10 in the first post. What is your service manager then if you do not use systemd – BarBar1234 Dec 5 '19 at 20:18
  • Devuan is Debian without systemd. You can use sysvinit, openrc and maybe upstart. – einpoklum Dec 5 '19 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.