0

I've a couple of Linux servers, one setup as a SAMBA AD (ubuntu 18.04), the other as a member server (ubuntu 16.04) setup as a file server.

It was working for a time, but now newer users created (successfully) on the AD server via users and computers (on a windows machine), are not able to use their credentials against the member server. Existing users can use their details normally, and this also syncs password updates etc.

These users are able to use their credentials directly against the AD, for example on login to a domain machine, but not to connect to the fileserver.

to demonstrate the problem fully, I can use 'getent passwd' on the member server, and it gives me a list of users, but not the full list of users from AD. Any user created recently is missing.

How can I diagnose the issue?

N.b 1 - It's not a server I've setup or configured, I've inherited responsibility for it from a leaving staff member.

N.b 2 - I've done the normal searching, and generally only found similar issues which relate to getent only showing local users, which isn't the case for me. (e.g LDAP: getent passwd don't show my recent user addition)

  • 1
    How is your member server connected to AD? winbind or sssd? – roaima Dec 3 '19 at 11:55
  • @JeffSchaller I'd take advice on where is most appropriate. U&L is looking better already. – Stese Dec 3 '19 at 12:51
  • Mmm. What are you using to link your member server to AD? – roaima Dec 3 '19 at 14:06
  • 1
    removed my comments as I had made a mistake, winbindd is on the system, so I'd assume that is what was used. how can proceed from here? – Stese Dec 3 '19 at 15:10
  • If you do getent passwd fred, where fred is one of the users that is supposed to be in your list but isn't, does it give you a valid answer? – roaima Dec 3 '19 at 15:54
0

I checked the Active Directory attributes of a user who was showing up and another who wasn't.

I found that the users who were not showing were missing a gid, uid and uidNumber.

Entering these values and waiting a few moments for the user to populate shows the user when a 'getent passwd' command is used on the member server.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.