I'm running Ubuntu Bionic Beaver inside VirtualBox with Arch Linux 5.3.12 as the host operating system.

I've selected the default options while going through VirtualBox' "Create Virtual Machine" dialog.

I've installed guest additions using pacman -Sy virtualbox-guest-utils.

This is what I see:

screenshot Ubuntu inside VirtualBox with lots of space unused

Ubuntu doesn't fill the available space and it doesn't adapt its size when resizing the VirtualBox window.

How can I make Ubuntu inside VirtualBox use all that empty space?

  • You need to install Guest Additions on the guest, not the host. Dec 2, 2019 at 18:42

1 Answer 1


Select VBoxSVGA as the graphics controller

You can fix this by selecting VBoxSVGA in the VM's settings. Go to "Display" → "Screen" → "Graphics Controller":

VirtualBox graphics controller settings

This way you get a guest operating system that fills the whole window:

Ubuntu with VBoxSVGA

The default graphics controller for Linux guests is VMSVGA. Here's an explanation of the different graphics controllers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.