I am trying to do sudo apt-get install kali-Linux-full I'm running into this error that's preventing me from going further. I've tried to clean the file and also remove it but I don't have permissions even though I'm Root. New to Linux so any help, tips, or tricks would be really appreciated.

root@host:~$ sudo apt-get install kali-linux-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
kali-linux-full is already the newest version (2020.1.0).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 kali-linux-large : Depends: jsql-injection but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
root@host:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  freeglut3 gir1.2-notify-0.7 gir1.2-packagekitglib-1.0 gir1.2-polkit-1.0 gir1.2-secret-1
  ibverbs-providers libhwloc5 libibverbs1 libpackagekit-glib2-18
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1643 not fully installed or removed.
Need to get 0 B/1,982 kB of archives.
After this operation, 2,257 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
E: Invalid archive signature
E: Internal error, could not locate member control.tar.{zstlz4gzxzbz2lzma}
E: Prior errors apply to /var/cache/apt/archives/jsql-injection_0.81-0kali2_all.deb
debconf: apt-extracttemplates failed: No such file or directory
dpkg-deb: error: '/var/cache/apt/archives/jsql-injection_0.81-0kali2_all.deb' is not a Debian format archive
dpkg: error processing archive /var/cache/apt/archives/jsql-injection_0.81-0kali2_all.deb (--unpack):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Check a ls -l /var/cache/apt/archives/jsql-injection_0.81-0kali2_all.deb and see if it's the expected size; are you out of disk space on /var? A sudo apt-get clean might clear out partial/mistaken downloads.
    – Jeff Schaller
    Nov 30, 2019 at 20:20
  • I tried to use sudo apt-get clean and my result was W: Problem unlinking the file jsql-injection_0.81-0kali2_all.deb - pkgAcquire::Clean (13: Permission denied) Nov 30, 2019 at 20:24

1 Answer 1


I encountered this issue. To resolve it I renamed the deb file and then performed the update successfully.

sudo mv /var/cache/apt/archives/jsql-injection_0.81-0kali2_all.deb \
sudo apt-get install jsql-injection

After this I went back to doing the other installations. Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .