First of all, I'm a Linux entrant. So, I have very rudimentary knowledge of this. And the device specifications for installing Linux are as follows:

AMD Ryzen 5 14nm Technology
BIOSTAR Group A320MH (AM4)
BenQ GW2470 (1920x1080@59Hz)
8192MB ATI Radeon RX 590 Series (ATI AIB)

For your information, I made a boot USB and proceeded with the installation.

I am a user of RX590 graphics card. I recently tried to install Linux distribution on my computer, but it doesn't proceed beyond the black screen. However, the black screen does not appear in Safe Graphis mode.

But install it in Safe Graphis mode, As the Safe Graphics mode is released when the installation is complete, nothing is visible again on the screen.

During installation, the console displays a cautionary phrase, VGA or graphics related error. The following error occurs before the desktop is visible when entering the Safe Graphics mode:

[     0.805320] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.

The screen is not visible unless enter the Safe graphics mode.

I thought this would only happen in Ubuntu, but the same shape occurs in every distribution. Obviously, previously it was possible to install Ubuntu and Manjaro(Xfce, Gnome, KDE), but somehow now it's impossible.

Many people asked me to set up a nomodest, but it was already Reset. Related Ubuntu 19.10: enter image description here

  • You say that you have tried every distribution. Are you sure? Can you edit your question to be specific. And mention your graphics hardware near the top of the question. Hope you get an answer (all I know is that AMD is a pain: they actively make things hard for the device driver writers). But maybe some one will know what to do. Nov 30, 2019 at 13:46
  • @ctrl-alt-delor The graphics card's supports a lower version of the Linux AMD display core. The problem is resolved with amdgpu.dc=0. Thank you for your kind knowledge.
    – bakuiseok
    Dec 2, 2019 at 12:27
  • Can you add an answer. It may be useful to others, or you in the future. Dec 2, 2019 at 18:53
  • @ctrl-alt-delor Can I answer my question? If possible, I'd be happy to contribute here.
    – bakuiseok
    Dec 3, 2019 at 6:12
  • Yes. I don't think that you need extra privileges to answer your own question. There is a button near the bottom. of the page. In one of the help pages it says that answering your own questions is encourages. You can even post a question and answer simultaneously. You can then get votes for the question and the answer. Ping me a comment, and I will up-vote both (if well written). Dec 3, 2019 at 19:24

1 Answer 1


I solved the problem that I saw only on Linux 18.x.x with Ubuntu 19.10 and 18.04, Manjaro 18.1.3.

From what I've found, the Radeon graphics card I'm currently using now supports Linux's low-level graphics driver core.

Currently, only RX470 and RX580, and RX590 devices are found to have problems. If you have any more problematic devices, please let me know in the comments. Of course, I think other distribution versions are possible with this same solution. However, there may be exceptions, See my solution for reference only.

At initial boot, if you install Linux through the in the grub menu and reboot again, the settings are initialized and the screen is not visible again.

Follow the following easy steps:

Step 1. When installing Linux, access the grub menu and insert the following code into the entry editor through E key:

amdgpu.dc=0 And, boot again through Ctrl+X key.

Make sure to remove the nomodeset and put amdgpu.dc=0 in the position. Usually, the nomodeset is located next the quiet splash.

Please refer to the following link for above parameters.

See the Reddit the following points for the amdgpu.dc.

Step 2. Please complete the installation and boot with amdgpu.dc=0 mode again.

Now, the settings you set at boot time are initialized when you reboot. Therefore, the settings for grub must be saved using the terminal.

Step 3. Open the terminal and enter the following command to open the grub setting:

sudo nano /etc/default/grub

And find And find GRUB_CMDLINE_LINUX_DEFAULT. Add the following code at the end or after quiet splash. Then save and update the grub settings.

sudo update-grub

Then reboot again.

  • Thank you! Works on Mageia 7.1 too.
    – jobukkit
    Jun 5, 2020 at 13:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .