1

I am using a laptop and I have the sound muted but when in settings and I press backspace while search something it beeps loudly and I can’t find a way to turn it off.

3
  • Does the beeping stop after you stop pressing backspace? – Jeff Schaller Nov 29 '19 at 21:01
  • 1
    You can either disable the Terminal bell in your terminal settings or remove the pcspkr driver using modprobe -r pcspkr – Valentin Bajrami Nov 29 '19 at 21:08
  • how do i get to the terminal settings – Tyler Nov 29 '19 at 21:17
2

I was looking to find a solution to this problem to turn off the beep in cherrytree note editor.

Editing inputrc did not work, but thanks to this post: https://sleeplessbeastie.eu/2012/12/28/debian-how-to-turn-off-the-system-bell/ I managed to turn off the PC speaker beep:

  1. create the file /etc/modprobe.d/pcspkr-blacklist.conf
  2. add the following line: blacklist pcspkr
  3. sudo depmod -a
  4. sudo update-initramfs -u
  5. reboot
0

The beeping comes by default from Kali Linux and it has many reasons why it beeps. One way to turn it off, is by opening a terminal and write: gedit /etc/inputrc you have to find a line which tells # set bell-style none you have to remove that hashtag, save it and it should work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.