5

I'm running a current version of Arch Linux (KDE) on a Dell laptop.

When I press the Meta key (with the Microsoft logo) it brings up the application launcher menu+. So it's not a dead key. And Ctrl works as expected.

However, Ctrl+Meta does not highlight the pointer / cursor position, nor does clicking the mouse animate anything, despite having both "Mouse Click Animation" and "Track Mouse" checked in the Systems Settings / Desktop Effects configuration, and confirming that the key binding for "Track Mouse" has both "Ctrl" and "Meta" checked.

I tried a variety of other finger-yoga contortions, but was unable to locate whatever magic combination would work.

Is there some common application or setting that might be overriding the above? (I don't believe I'm running anything especially peculiar enough to override KDE / Plasma.0

3
  • 2
    The default keys to activate this on my Arch distro is meta+*, not meta+ctrl. If i change to ctrl+meta it doesn't work. Try another combo?
    – bu5hman
    Nov 29 '19 at 20:13
  • 1
    Just using two modifier keys won't do anything. Combine one or more modifier keys with a "normal key". It's meta+* for me as well on Kubuntu 18.04.
    – DK Bose
    Nov 30 '19 at 13:10
  • 1
    Both answers helped: meta-* toggles the mouse animation, which I didn't know I needed to toggle on. The default for "track" didn't work with any meta+[x] and I had to switch to alt+/. Thank ye both. Nov 30 '19 at 21:34
7

I use KDE version 5.6 and in order for mouse tracking to work I actually need to do the following:

  • Go to the System settings.
  • search "Track mouse", it should be in the "Desktop effects" submenu.
  • Enable it by ticking the checkbox.
  • Mouse over the Track mouse and then click on the "configure" which should appear as settings icon on the left.
  • As shortcut, I have unchecked "meta" and everything else. Then I clicked "none" to set a shortcut. Then I pressed the F12 key. Then I clicked OK.

If it still does not work, then in System Settings, search for "compositor" and enable it. It happened to me that it was disabled automatically because it crashed.

That's it.

The screenshot is an example which uses different keys.

This is the settings screen:

Here is how the settings look for me

Cursor is highlighted like this:

highlighted cursor

1

To make the cursor more visible:


KDE menu

  • settings

  • system settings

  • workspace behavior

  • desktop effects

  • (check the option:) track mouse

  • (hover over "track mouse" to let the two buttons appear on the rightmost side)

  • (click the button which shows the "configure" tooltip)

  • (uncheck all the "modifier keys", which in my tests were ignored anyway)

  • none

  • (press a key of your choice; I chose the F12 function key)

  • OK


Now close "system settings" and if it asks "apply, discard, cancel" then click "apply".

Press the F12 function key to activate or deactivate the effect.

If it still does not work, then do as follows:


KDE menu

  • settings

  • system settings

  • display and monitor

  • compositor

  • (check:) enable compositor on startup

  • (log out and log in, or just reboot)


It happened to me that it was disabled automatically because the graphics driver crashed.

2
  • How is this different than the existing answer unix.stackexchange.com/a/570608 ?
    – guntbert
    Jul 25 '20 at 20:38
  • @guntbert Indeed I first posted this as an edit to the answer that you mention, but it wasn't published.
    – salvador
    Jul 28 '20 at 13:24
1

The default configuration on Arch/KDE5 is Ctrl+Meta keys PLUS moving the mouse cursor. This may appear somewhat unintuitive, particularly for users coming from other GUIs (like Ubuntu 16 with Gnome) where just a modifier key press alone shows a pointer animation already with no mouse action required; also, for physically handicapped users it may be easier to activate than KDE's approach.

1
  • Yes, that was that. I was thinking the effect was broken or unresponsive (holded for a time, then it sometimes appeared). Then realized it was because you need to move mouse a bit. I have filed bug report for that: bugs.kde.org/show_bug.cgi?id=444271
    – Ashark
    Oct 23 at 14:26
0

Just to enrich the post, on Manjaro (Cinnamon) that. check the

  • System settings -> mouse -> show position when ctrl is pressed

I was surprised arch has built-in such capability, I can confirm this on Manjaro that released in 2021.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.