2

I have bought new PC with AMD Ryzen 7 3800X and Radeon RX 5700 XT.

Can only install from UEFI USB stick otherwise installation after first dialog (the one where you select Install or Graphical Install) is just broken mess.

When installed, OpenGL uses CPU rendering instead of GPU and no drivers can do anything with it. I have tried many things from xserver amdgpu package to official amdgpu pro but none of them works (amdgpu pro cannot be installed because it breaks during configuration).

After OS installation I do not get KDE to load even tho it is installed. I need at least some firmware to startx but having working xserver breaks TTY (full-black screen but I can successfully login and then run startx as if nothing bad was happening).

This could be OK-ish (not good but can hopefully live with) but I cannot get OpenGL to run on GPU. Still, it glxgears run on more than 2 thousands compared to 60 on my old laptop.

And in addition I never got my 2nd monitor working (main using DisplayPort, secondary using HDMI) even tho both my monitors are connected to the GPU.

What I did not try was getting everything from source and compile it myself (it is 4:30 AM here now and I am tired of spending most of my day on it).


PS: Running Debian Sid with 5.3+ Kernel 19.2+ Mesa, amd64 (+i386 using multiarch).

PPS: Had to use other mirror than deb.debian.org because there was something broken which caused much more problems.

2

Solved by installing firmware-linux-nonfree and then running make install in git.kernel.org/.../linux/kernel/.../linux-firmware.git/ (just download it, extract the .tar.gz and while in the directory type "make install").

This way you should be able to use all the new firmware until it is replaced by newer version from your distro.

  • There's newer GPU firmware now for RX 5700. You should recommend downloading the current master instead of that specific commit. – tambre Dec 20 '19 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.