According to this manual I tried:

$ iwconfig
lo        no wireless extensions.

eth1      IEEE 802.11bg  ESSID:"g\xC6isQ\xFFJ\xEC)\xCD\xBA\xAB\xF2\xFB\xE3F|\xC2T\xF8\x1B\xE8\xE7\x8DvZ.c3\x9F\xC9\x9A"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

$ sudo ifconfig eth1 up

Then I used wicd from this manual. It will find my wireless router, but when I click connect, the phase obtaining IP address is endless.

I tried:

$ sudo iwlist scan
lo        Interface doesn't support scanning.

eth1      Scan completed :
          Cell 01 - Address: C8:3A:35:1F:60:78
                    Protocol:IEEE 802.11bg
                    Frequency:2.412 GHz (Channel 1)
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 11 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Quality=97/100  Signal level=-27 dBm  
                    Extra: Last beacon: 172ms ago

eth0      Interface doesn't support scanning.

Here is the content of /var/log/wicd/wicd.log

Could you advise me how can I connect and how to correctly set /etc/network/interfaces?

| improve this question | | | | |
  • Is there anything salient in /var/log/wicd.log? – Chris Down Nov 11 '12 at 18:11
  • @ChrisDown There was a lot of information from last two hours, so I decided to remove this file to have it clean. But the log information is not written in there now. There seem to be problems with DHCP. – xralf Nov 11 '12 at 18:36
  • It's probably still writing to the same FD. Try removing it and then restarting the wicd daemon. – Chris Down Nov 11 '12 at 18:54
  • 1
    This is the content of the log file. – xralf Nov 11 '12 at 19:01
  • Perhaps a silly question, but do you have DHCP enabled on the router? Are there any access controls in place (MAC filtering etc.)? – peterph Nov 14 '12 at 10:33

Try running wpa_supplicant directly: put your wireless configuration in /etc/wpa_supplicant/wpa_supplicant.conf (or where ever it is ocated on your system) - for small (home) networks it usually looks similar to this (real-life, yet still mostly copied from wpa_supplicant.conf man page):

    ssid="<your SSID goes here>"
    psk="<your password goes here>"
    pairwise=CCMP TKIP

Then run wpa_supplicant:

$ wpa_supplicant -D wext -i eth1 -c /path/to/wpa_supplicant.conf

Once it associates with the network, run your dhcp client, e.g.:

$ dhcpcd -d -n eth1

This way you'll be able to see, what's happening behind the scenes, since the utilities report to standard error.

| improve this answer | | | | |
  • This ends with this error message. – xralf Nov 14 '12 at 18:40
  • ioctl[SIOCSIWENCODEEXT]: Invalid argument - what wireless card do you have? Using another driver (the -D option) might help. – peterph Nov 14 '12 at 21:08
  • I'm using Intel 2200BG. I tried to use wpa_supplicant -D ipw2200 but it shows a message unsupported driver ipw2200. – xralf Nov 15 '12 at 9:54
  • I'm at my wits end. :( Is there anything interesting in dmesg or system logs around the time, wpa_supplicant uses invalid ioctl argument? – peterph Nov 15 '12 at 10:04
  • Thanks, I will try to bounty the question. I don't know how to search in dmesg according to time. – xralf Nov 15 '12 at 11:25

Firmware Update

The first possible side of the problem is firmware. First of all, ensure you have installed it:

$ sudo-apt-get install firmware-ipw2x00

If it still would not work, you can try download a new firmware from here corresponding to your kernel driver version. To determine the deiver version use:

$ dmesg | grep ipw2200

There you should see something like:

ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 3.0`

After downloading the tarball you have to extract it and put to /lib/firmware:

$ tar -xzvf ipw2200-fw-3.0.tgz
$ sudo mv ipw2200-fw-3.0 /lib/firmware

And then reload the kernel module (or simply reboot if you wish):

$ sudo ifconfig eth1 down
$ sudo rmmod ipw2200
$ sudo modprobe ipw2200

Kernel Driver Update

If it still not working then you can try to upgrade the whole kernel to a bleeding edge version and check whether it would work there.

You can obtain a fresh compatible package from this ubuntu repository. Download all three packages corresponding to your architecture.

Then, simply install them:

$ sudo dpkg -i linux-headers-3.6.3-030603-generic_3.6.3-030603.201210211349_amd64.deb
$ sudo dpkg -i linux-image-3.6.3-030603-generic_3.6.3-030603.201210211349_amd64.deb
$ sudo dpkg -i linux-image-extra-3.6.3-030603-generic_3.6.3-030603.201210211349_amd64.deb   

It should update bootloader and generate initramfs automatically and all you have to do at this point is to reboot and choose the new kernel in the bootloader menu.

Also perhaps you have to download a new version of firmware (described in previous session) corresponding to the new driver version.

| improve this answer | | | | |
  • dmesg | grep ipw2200 gives me ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq so I downloaded firmware v1.2 (ipw2200-fw-1.2.tgz). After extracting the archive, there are five files (ipw2200_boot.fw, ipw2200_bss.fw, ipw2200_ibss.fw, ipw2200_ucode.fw, LICENSE). Now, it's not clear which of them should I copy to /lib/firmware. – xralf Nov 23 '12 at 8:23
  • It seems early driver versions doesn't have a separate folder. Put all these four *.fw files to /lib/firmware directly. – Dmitry Nov 23 '12 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.