0

I can't login anymore into my encrypted disk. After writing the password:

error: no such cryptodisk found.
error: disk ‘cryptouuid/HEXstring’ not found.
Entering rescue mode…

intuitively that string is the identifier of the disk that I'm trying to decrypt and log into.

So I live boot from USB and go into file manager, mount the encrypted disk and I can access it, since I know the correct password.

My resources are a live USB and every file I want from my encrypted disk, since I actually can enter into the partition.

History of what I've done before rebooting and finding this problem:

  • masked the swap unit
  • deleted the partition where the swap unit was

How can I fix the system not recognising my cryptodisk during boot?

0

I tried to do something alone (yes, I'm the answerer to my own question. I was panicking) and I did this in order to re-access my account:

  • after I ran the live USB, I mounted my linux partition so that I could access to its files. I personally did it from the file manager but you can use the mount function.
  • with the sudo command I opened /etc/default/grub with a text editor
  • uncommented the voice "GRUB_ENABLE_CRYPTODISK=y" It will allow the system to boot from an encrypted disk, where the grub file configuration is located.

I'm not an expert neither in Linux systems neither in programming, so I don't know if this was a good method. Anyways I thought about this because I found, in /boot/grub/grub.cfg :

`if [ x$feature_platform_search_hint = xy ]; then

search --no-floppy --fs-uuid --set=root --hint='cryptouuid/HEX_string_of_my_encrypted_disk'

else

search --no-floppy --fs-uuid --set=root HEX_string_of_the_swap_partition

So I thought it was selecting, as the bootloader disk, the swap partition of my cryptodisk instead of the actual cryptodisk and that's why I searched for the option above written and un-commented it.

Right now the system runs ok, but at the beginning a message has been sent through the screen, which was something like:

hibernation device not found

or something very similar. Which I guess it's just expected since I have no swap memory anymore.

So, this is ONE solution, again, not sure if the best.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy