1

In less command there is a handy feature - live tail which is enabled via Shift+f when viewing a file.

However it has a built-in caching - it doesn't output anything until it meets a newline symbol. Thus when your script outputs something like "1 2 3 4 5..." without newlines then less won't display it in real-time.

Is that possible to avoid this caching? Maybe with another command which does the same?

Upd. More details about my case. I'm connecting to Ubuntu server over SSH via Putty. And when I'm using less live tail then it outputs data only when it either fills whole screen width or contains a newline. Maybe it's not less caching but Putty instead?

1 Answer 1

1

Your experience in PuTTY matches mine in iTerm2 (Mac), so I don't think it's your client.

If you don't need the interactive features of less, you could try tail -f -- this seems to handle the lack of new lines better.

3
  • I'm marking this as correct answer because it actually solves the announced issue. However this way is far from ideal. When I run it in a virtual machine then it alerts tail: cannot determine location of 'file.log'. reverting to polling: Input/output error. On a real ubuntu server works fine. However it's not that convenient as less because it simply outputs everything into terminal. In less you can hit Ctrl+c and then quit back into terminal without wasting it. Anyway thanks
    – Stalinko
    Dec 10, 2019 at 9:14
  • Maybe you need tail -F or tailf if the file is being turned rotated beneath your feet?
    – bxm
    Dec 10, 2019 at 11:46
  • tail -F outputs same error but multiple times :) well it's not such big deal to waste time for this. I'm fine with tail -f on my ubuntu server. At least it allows to see real time progress without waiting for newline.
    – Stalinko
    Dec 10, 2019 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.