0

External multicast data is being received by machine #1 and forwarded to machine #2. On machine #2 I can see the multicast packets being received when I use tcpdump, ethtool and netstat -i (ethernet layer).

However, when I run netstat -s -u the number of UDP packets isn't increasing, nor is InMcastPkts but InOctets is increasing. So my guess is packets are being dropped in the IP or UDP/TCP layer?

How can I confirm this and what would be the most-likely cause of the packet-loss?

1 Answer 1

0

Do you have any piece of software on machine #2 that do a "IGMP JOIN" on the multicast group ?

The principle of multicast is that you must join the group to get the trafic or it get dropped.

1
  • I have an application which subscribes to the group and listens for packets but it's not receiving any. The app was listening when i ran the commands
    – user997112
    Commented Nov 26, 2019 at 16:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .