6

I've been trying to install pgAdmin4 from postgresql repositories, but I keep getting following error:

Err:1 http://deb.debian.org/debian buster/main amd64 python3-werkzeug all 0.14.1+dfsg1-4
  404  Not Found [IP: 151.101.112.204 80]
E: Failed to fetch http://deb.debian.org/debian/pool/main/p/python-werkzeug/python3-werkzeug_0.14.1+dfsg1-4_all.deb  404  Not Found [IP: 151.101.112.204 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I tried running sudo apt-get update multiple times, but it didn't solve the issue. I also found the directory in debian repo http://cdn-fastly.deb.debian.org/debian/pool/main/p/python-werkzeug/ and there really isn't the file I need. Should I somehow change my sources.list or mail to people from debian or is that somehow my fault? I'm really new in this, so thanks for begin patient. (I read similar questions from other people, but none solved my error and I couldn't think of how to apply it on my case.)

Edit: I have Debian 10 Buster.

8
  • If you have added the repo you should delete from sources.list, since this one doesn't work. Nov 26, 2019 at 11:56
  • What's your debian version? Nov 26, 2019 at 11:57
  • I have debian 10. And I deleted everything that I added to my sources.list file.
    – kytka
    Nov 26, 2019 at 11:59
  • As I see it, you shouldn't need to add any extra repositories. When you clean your sources, you must install apache2 [apt install -y apache2] (required by pgadmin4) and then proceed to its installation [sudo apt-get install pgadmin4 pgadmin4-apache2] Nov 26, 2019 at 12:07
  • I undid everything I did earlier in sources.list and then I did apt install apache2 (install-and doesn't work) and it worked fine, then I did sudo apt-get install pgadmin4 pgadmin4-apache2 and it said that a lot of new python packages will be installed (python3-werkzeug included) and then the same error message.
    – kytka
    Nov 26, 2019 at 12:14

2 Answers 2

3

Check your /etc/apt/sources.list.d/ directory as well as your /etc/apt/sources.list file for any entries hinting at the repository that apt doesnt like.

Delete those entries, then run an apt update

1
  • 3
    I did this and commented out main repo. Then did sudo apt update, which caused a lot of errors, so I uncommented it and did sudo apt update again. It installed a lot of new stuff that I didn't know about (even though I did that regularly before, can somebody explain that to me?) and then I tried sudo apt-get install pgadmin4 pgadmin4-apache2 and it worked all of a sudden. I really don't get it. Got any explanation? I'm really curious.
    – kytka
    Nov 26, 2019 at 15:29
0

As done above, I removed the important source from /apt/etc/sources.list and got a pile of errors during apt-get update, so I restored /apt/etc/sources.list and got errors about unacceptable version changes.

In /etc/apt/sources.list, I recorded that I updated the kernel via sudo apt-get -t bullseye-backports upgrade. Maybe it was the cause, I don't know. Either way...

The original 404 Not Found problem was solved via:

sudo apt-get --allow-releaseinfo-change update

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .