0

Context:

I installed ubuntu 18.04 on a lenovo legion y540 laptop with dual hard disks. ubuntu 18.04 on 128GB m.2 and windows 10 on the second drive-ssd. When I installed ubuntu I chose 15GB swap space. The machine has 16GB ram.

Problem: When I open system monitor application, it shows the system as 2gb of swap but on the 'disks' app, it shows the swap as 15gb as I allocated. Why is this discrepeancy?

system monitor and disks output

0

Your 15GB partition isn’t active (“Swap (version 1) — Not Active”), so that’s not where your system is storing the 2GB of swap it’s configured with. I’m guessing your active swap volume is on your other drive, or in a file.

To see what swap is in use, run

/sbin/swapon

in a terminal.

To enable your 15GB swap partition, add

UUID=33e3aead-68d1-4e67-98f7-2fcb2150bcf9 swap swap default 0 0

to /etc/fstab, and run

sudo swapon -a
  • Thanks for the answer. The result says /swapfile file 2G 0B -2. How do I 'activate' the swap that I created? – alonzo golanzo Nov 25 '19 at 10:18
  • See my updated answer. – Stephen Kitt Nov 25 '19 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.