0

I own a Lenovo X220 (since 2011) and never had serious problems with it. The suspend-to-ram feature worked almost its whole life (it was a Linux machine the whole time, but the disto changed from time to time).

For the last weeks I fought with suspend issues and I don't know what to try next.

Problem: After I go into suspend mode the display turns off and the power led begins to blink. But the bluetooth, mute and microphone-mute LEDs stay on and the fan continues spinning. Than after ca ~30 seconds the machine powers off. That means no suspend. Next boot starts with a fsck.

When shutting down there is a similar issue. The shutdown process runs smoothly and ends with the lines:

Reached target shutdown.
reboot: power down

but it also takes ~30 seconds until the machine powers off. Maybe the two problems are related.

Additional info:

  • System: Arch Linux (latest updates)
  • Lenovo X220i Tablet, 8GB Ram, no discrete grafics card
  • the problem occurs in ~9 out of ten attempts
  • I already tried booting Live Distribution (latest KDE Neon and Ubuntu 18.04 (the one from 04/18 not the 18.04.3, as I am sure it worked back then)). Same issues.
  • I did a BIOS upgrade to the latest version 1.46 and a BIOS reset
  • I tried live usb with the internal drive (ssd) removed
  • I tried the same without battery (only connected to AC)

Does anyone has an idea how to solve it? I will provide any data and try everything. Thanks in advance.

1
  • I have a X220s, and while it is not identical, it is prone to the same issues. You should submit a bugreport.
    – user2497
    Nov 25, 2019 at 11:07

1 Answer 1

0

I fixed it! The memory was to blame...or something with the memory.

And yes - I tested it before (Memtest was one of the first diagnostics I ran). But it didn't report any issues. But a few days ago I removed one of the ram modules (there were 2 x 4GB). After that (running on 4GB) there were no more issues. I switched both modules and now have 8GB (2x4GB) again. Still running fine for a few days. I also tested the modules again with memtest, no issues like before.

Interesting behavior for a ram issue. I hope someone with the same problem stumbles over this answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .