0

I'm not sure how this happened. Maybe it was when I was adding a second layout to my keyboard somehow (although I only added another language).

When I press caps, which I only use and have only used to capitalize alphabetical characters, now I get the behavior of shift: the spacebar doesn't work, numerical character such as 123 become !@#. This greatly affects my workflow in a negative way.

When I run setxkbmap -query this is what I get back:

rules:      evdev
model:      pc105
layout:     us,il
variant:    intl,biblical
options:    caps:caps_toggle

And this is only after I tried running setxkbmap -option -option caps:caps_toggle. I've also tried the same with caps:caps_lock with no result.

Before I did this, -query returned

rules:      evdev
model:      pc105
layout:     us,il
variant:    intl,biblical
options:    caps:shiftlock,caps:caps_lock,caps:capslock,caps:none,caps:nocaps,caps:caps,caps:capslock,grp:toggle

Although the options are different, the behavior is the same.

I know this is an issue with the X keyboard, since this doesn't happend when I switch to a purely terminal screen.

2
  • Did you try restarting X after the reconfiguration?
    – bxm
    Commented Nov 24, 2019 at 13:24
  • @bxm yes, and it didn't work. I have also been able to enable or disable the caps key altogether by switching back and forth from -option -caps:none without restarting X. Commented Nov 24, 2019 at 13:30

1 Answer 1

0

Maybe it was when I was adding a second layout to my keyboard somehow (although I only added another language)

Yes. That was it. This has been happening for weeks, and I didn't have any idea that it could be due to variant of my second alphabet keyboard (biblical hebrew, to be able to write nikkud). When I changed it back to lyx the problem stopped.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .