1

A virtual machine with Windows 10 as the guest's OS is set up using KVM/QEMU.

Without SPICE, it worked perfectly fine but for clipboard sharing, I followed Arch Linux's Guide. But then it's super annoying since everytime virt-viewer's window size changes, the guest's resolution becomes unexpected and I cannot see all content on the screen.

My qemu parameters:

#!/bin/bash
qemu-system-x86_64 -boot c -m 4.5G \
-drive file=win10.img,format=raw,index=0,media=disk,if=virtio,aio=native,cache=none \
-enable-kvm \
-machine q35 \
-device intel-iommu \
-cpu host,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
-smp 4 \
-net nic,model=virtio \
-net user,smb=/home/tek/data \
-soundhw hda \
-usb -device usb-tablet \
-vga qxl \
-device virtio-serial-pci \
-device virtserialport,chardev=spicechannel0,name=com.redhat.spice.0 \
-chardev spicevmc,id=spicechannel0,name=vdagent \
-spice unix,addr=/tmp/vm_spice.socket,disable-ticketing \
-display spice-app

Is there a way to disable SPICE's dynamic screen resolution since I don't find it useful but still retain the ability to share clipboard or fix this weird phenomenon?

The lower right part of the screen is not visible (especially the clock), and my screen's native resolution is only 1920x1080

Screenshot

0

Adding a comment as an answer:

Replacing "-vga qxl" with "-device qxl-vga,max_outputs=1" solved the problem for me. https://wiki.archlinux.org/index.php/QEMU#QXL_video_causes_low_resolution

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.