1

apk add/del is reporting errors after any operation. It's always 2 errors. For example (coreutils is already installed):

$ sudo apk add -vv coreutils
After this operation, 0 KiB of additional disk space will be used.
2 errors; 3182 MiB in 839 packages

$ echo $?
2

The correct output should be OK: 3182 MiB in 839 packages.

Is there any way to fix this — or, at the very least, get more detailed error info? There's nothing in /var/log/messages, and I couldn't find anything in the documentation.

If it helps, I checked the source code and the errors are being printed in src/commit.c:358... Seems to be related to a database issue of some sort?

Any ideas?

2
  • Have you tried apk fix ? I am pretty sure that it is not problem with coreutils then rather is a problem with some other package you've installed previously.
    – fugitive
    Nov 19, 2019 at 7:42
  • @fugitive Yep that fixed it -- added it as answer. Thanks!
    – ezzzc
    Nov 19, 2019 at 21:53

1 Answer 1

3

As suggested by fugitive and _ikke_ on IRC, apk fix resolved the issue automagically 🎉

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .