2

At the bottom of rkhunter.conf (I also tried placing it separately in rkhunter.conf.local), and after checking for invisible chars,

Unknown configuration file option: CRON_DAILY_RUN="false"

Unknown configuration file option: CRON_DB_UPDATE="true"

Unknown configuration file option: APT_AUTOGEN="true"

Comes up for rkhunter -C. rkhunter is Version 1.4.6-5 from Maintainer: Debian Security Tools on Debian 10.1.

I already tried purging and reinstalling. Inserting other options in rkhunter.conf.local, such as UPDATE_MIRRORS=1 or ALLOW_SSH_ROOT_USER = yes, does not trigger a warning. Only these three give issues.

PS: I say rkhunter.conf.local but it doesn't matter, the result is the same if I edit rkhunter.conf directly.

  • What editor did you use to edit the file? What does the previous line (the non-blank one above the first error line) say - is it valid? – roaima Nov 18 '19 at 17:54
  • show (the relevant part of) rkhunter.conf.local – Bodo Nov 18 '19 at 18:01
  • rkhunter.conf.local: i.imgur.com/CZp6Ni9.png @Bodo – Gaia Nov 18 '19 at 19:26
  • 1
    @roaima when it was in rkhunter.conf, the previous line was either blank or a comment (I tried both). in rkhunter.conf.local see the comment above. I used nano to edit it, and already removed all CRLF and inserted again, all in nano. – Gaia Nov 18 '19 at 19:27
0

These three options need to be set in /etc/default/rkhunter, not rkhunter.conf or rkhunter.conf.local!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.