1

I am running ubuntu 19.04 (disco) in the latest VirtualBox and all was running fine until I tried to upgrade LBLIBCXX_3.4.21 to fix the error below. I used dpkg to force install lib64stdc++6_9.1.0-2ubuntu2_19.04_i386.deb. Then after reading it complain about gcc-9-base being out of date, I tried apt install gcc-9-base that only returns the following error message.

ImportError: /lib/x86_64-linux-gnu/libapt-pkg.so.5.0: symbol _ZTVNSt7__cxx1119basic_istringstreamIcSt11char_traitsIcESaIcEEE version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference

I tried the following suggestions but could not find a solution: https://askubuntu.com/questions/777803/apt-relocation-error-version-glibcxx-3-4-21-not-defined-in-file-libstdc-so-6

What do I need to do to get apt install working again?

2 Answers 2

2

There are a few things that have gone wrong here. Since apt is showing an error concerning /lib/x86_64-linux-gnu/libapt-pkg.so.5.0, you’re presumably using amd64, not i386, so you should re-install the amd64 package of libstdc++6 and remove the i386 package you force-installed.

You can download the packages you need directly:

Install them with dpkg, forcing if necessary (packages should never be force-installed, but fixing a forced installation often involves more force-installing).

0

After reading my .bash_history file, I learned I had attempting to install libstdc++6 modules for a different reason, to unpack my android apk files. Once I realized how many different attempts I tried to get java and dex files to operate with libstdc++6, I decided it would be better to restart my build with a clean build instead of recovering from my failed attempts. I appreciate the suggested solution but because of the overwhelming version changes since 2017 in android, my whole project was aborted due to hardware and internet services deprecation. Ubuntu was the only possible option to make it possible. Unfortunately, the destination IoT android tablet platform has been bricked by Google Photos API deprecation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.