1

I have a Dell Latitude 5500 Laptop with Debian 10 and KDE Plasma 5.14.5. I've had this laptop for about three months, and this just started a few days ago.

When I'm done for the day, I usually press ctrl-alt-L to lock it, then close the laptop lid. When I open the laptop lid the next day, both the external USB keyboard and the built-in keyboard do not respond. The only way I can unlock it is to use the mouse to go back to the switch session screen, and then both keyboards (external and built-in) will let me type.

I think this has something to do with closing the lid because if I lock it but leave the lid open, I've never had this problem.

I went almost three months without having this problem.

  • It might have to do with the fact the laptop goes to sleep. Try adjusting the acpi_osi kernel parameter but don't take my word for it. Sorry I can't be more helpful and even more sorry if I am misleading you. – muthuh Nov 18 '19 at 16:15
  • what happens if you re-plug the external keyboard? – jsotola Nov 18 '19 at 17:58
  • @jsotola I tried that and neither keyboard responded. I tried with the external both plugged and unplugged and neither worked. – raphael75 Nov 18 '19 at 20:07
  • what tests have you done with closing and opening the lid? .... you should have included everything that you tried when you first posted the question – jsotola Nov 18 '19 at 20:14
  • What do you mean by "tests"? What can I do other than open and close it? Because I couldn't type anything there was almost nothing I could do. – raphael75 Nov 19 '19 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.